Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Frequently there are questions about, how to manually install a font, what very often means “Type1 font”. So I thought, we should write a general answer about the several aspects to regard.

Beside the usual approach for manual installation of packages it seems, that for fonts further steps are necessary. What are these steps? Or better:

How to manually install fonts and their associated support files in TeX distributions?

share|improve this question

1 Answer 1

up vote 31 down vote accepted

Zeroth

Before you start make sure, that there is really no possibility for an installation with the package manager of your TeX distribution. For TeX Live see also the script getnonfreefonts (here on TeX.SX user dcmt wrote a nice answer as well) and this question and answer: Error in TeX Live – Font ... not loadable: Metric (TFM) file not found .

In wide parts already described in short in TeX Users Group: Installing TeX fonts.

Siep Kroonenberg describes a different method in Font installation the shallow way (PDF, website of Dutch TeX users group NTG; the same as TUGboat article: tb86kroonenberg-fonts.pdf.)

First

You have to install the font files into a local texmf tree.

  • For MiKTeX you perhaps have to create such a local texmf tree.

  • In TeX Live you somewhere have already a directory texmf-local for a system-wide local installation (system variable TEXMFLOCAL), but you can also create a user specific path (TEXMFHOME). To find out the actual paths or whether they already exist you can input kpsewhich --var-value=TEXMFLOCAL or with TEXMFHOME respectively.
    Installing of fonts in TEXMFHOME is not recommended, because afterwards you must do a manual update everytime any Type1 font (see below) related stuff is updated!

If the font package comes in a packed file, you can in most cases safely extract with subdirectories into this local texmf tree, but you should control this before doing so by comparing with the following tree structure. For instance perhaps all needed subdirectories are packed under a needless texmf directory.
Note: Sometimes map files are twice included there. In recent TeX distributions you only need the ones, which are found as mentioned below in <local-texmf>/fonts/map/<engine-name>/..., not these in <local-texmf>/<engine-name>/... – mostly <engine-name> is dvips, but sometimes also pdftex, and rarely just another one.

If there is no subdirectory structure in the packed file, you have to create it under <local-texmf> copying the structure of the according main texmf tree (known as TDS, the TeX Directory Structure) – here an almost full structure is shown (in the main texmf tree[s] it is actually more complex), for a single font package very likely only parts are necessary:

<local-texmf>
      +--fonts
          |--afm
          |   +--<font-package-name>
          |           +--<*.afm files>
          |--enc
          |   +--<engine-name>
          |           +--<font-package-name>
          |                   +--<*.enc files>
          |--map
          |   +--<engine-name>
          |           +--<font-package-name>
          |                   +--<*.map files>
          |--ofm
          |   +--<font-package-name>
          |           +--<*.ofm files>
          |--opentype
          |     +--<font-package-name>
          |             +--<*.otf files>
          |--ovf
          |   +--<font-package-name>
          |           +--<*.ovf files>
          |--ovp
          |   +--<font-package-name>
          |           +--<*.ovp files>
          |--pfm
          |   +--<font-package-name>
          |           +--<*.pfm files>
          |--pk
          |   +--<printer-type>
          |           +--<font-package-name>
          |                   +--<font-resolution>
          |                          +--<*.pk files>
          |--sfd
          |   +--<font-package-name>
          |           +--<*.sfd files>
          |--source
          |    +--<font-package-name>
          |             +--<*.mf files>
          |--tfm
          |   +--<font-package-name>
          |           +--<*.tfm files>
          |--truetype
          |     +--<font-package-name>
          |             +--<*.ttf files>
          |--type1
          |    +--<font-package-name>
          |            +--<*.pfa/*.pfb files>
          +--vf
              +--<font-package-name>
                        +--<*.vf files>

In the main texmf fonts tree(s) instead of <font-package-name> actually in almost all directories comes an additional <font-vendor> or public in between.

Also most fonts nowadays are shipped out as packages with documentation and style files. These come in

<local-texmf>
      |--doc
      |   +--fonts
      |        +--<font-package-name>
      |                |--<document files and their *.tex sources>
      |                +--<example files>
      +tex
        |--latex
        |    +--<font-package-name>
        |             |--<*.fd files>
        |             |--<*.sty files>
        |             +--<*.tex files [no document sources and examples]>
        +--plain
             +--<font-package-name>
                      |--<*.def files>
                      +--<*.tex files [no document sources and examples]>

Second

After copying the files you must update the file name data base of your TeX distribution:

  • In MiKTeX (note also Difference between administrative and user mode of MiKTeX )

    1. Using the GUI: In the Start Menu go to the MiKTeX entry and open the settings – if you act as admin respectively “Settings (Admin)”, of course. The “MiKTeX Options” window will open. Go to the “General” tab and click there on “Refresh FNDB” (FNDB = File Name Data Base).

    2. Using the CLI (command prompt): Execute initexmf --update-fndb (or shorter initexmf -u, as admin add the switch --admin).

  • In TeX Live

    • Linux and MacOSX: sudo mktexlsr (or, perhaps better to remember, with alias [symlink to mktexlsr]: sudo texhash.

    • Windows: mktexlsr (or the alias: texhash)

For MetaFont files (*.mf) this is enough.

For Open-/TrueType font files (*.otf/*.ttf, the directory names are misleading here, as the file extension does not say anything about OpenType abilities) you should additionally run fc-cache (MiKTeX and TeX Live Windows) or sudo fc-cache (TeX Live Linux and MacOSX) on the command prompt, but then you are ready as well. Nothing more needed for these fonts.

But note, that as long as you do not work with a portable TeX distribution it is quite probably better to install Open- or TrueType fonts into the system wide font directory since this is anyway searched and the fonts are added to the font cache with fc-cache.

MiKTeX portable users read also External font with portable MiKTeX, Version 2.9, please.

Third

For Type1 fonts (see Wikipedia, PostScript fonts) further steps are required:

  • In MiKTeX (for MiKTeX portable read also External font with portable MiKTeX, Version 2.9!)

    1. On command prompt (here no GUI possible) execute initexmf --edit-config-file=updmap.cfg (or initexmf --edit-config-file updmap). This will open your default text editor with the file updmap.cfg in your user profile under %AppData%\MiKTeX\<version>\miktex\config\. If it did not exist yet, it will be created.

      If you add the switch --admin, the file will be created/opened in %AllUsersProfile%\MiKTeX\<version>\miktex\config\ (since Windows Vista) or %AllUsersProfile%\<Application Data>\MiKTeX\<version>\miktex\config\ (until Windows XP, the string <Application Data> is language dependent) and will be valid for all users without an own file name data base.

    2. Add there at least the following (line with # is a comment, we assume here, the Map file has the name fontname.map).

      # <font name> or <package name> or what fits better for you
      Map fontname.map
      

      Save and exit. If there is more to do, this should to be read in a readme file. For information you could also open the online help page updmap.cfg or the updmap.cfg in your main MiKTeX\miktex\config installation tree and read the comments in it (but do not edit, as every edit will be lost on a later update!).

    3. Execute initexmf -u, this updates the font name data base only for the active user (you can leave this out, if you are sure, your local updmap.cfg already existed).

    4. Execute initexmf --mkmaps (or shorter updmap).

  • In TeX Live (assuming the according map file name is fontname.map)

    1. In Linux and MacOSX execute sudo updmap-sys --enable Map=fontname.map, in Windows updmap-sys --enable Map=fontname.map.

    2. Make again an update of the file name data base, see second step above.

    If you still have problems, you could try the approach given in this answer: Problems installing MathTime Professional 2 font on TexLive.

share|improve this answer
    
Note that pdftex can use truetype fonts natively, too. Some font packages require the same sort of handling as for type1 fonts except that the map file is not usually added using updmap-sys but specified in the .sty file so that step can be (and should be) omitted. (gtamac... packages are of this kind.) If metafont files are included in the package, you should use MixedMap. You don't need to update the filename databse a second time. mktexlsr $(kpsewhich --var-value TEXMFLOCAL) is quicker if you've installed into TEXMFLOCAL. –  cfr Mar 11 at 1:57
1  
Also, you may wish to clarify that this will not work for arbitrary type1 fonts - it assumes the support files already exist. In the opentype/truetype case, fc-cache will do nothing on many Linux systems (not sure about OS X) because the font directories in texlive will not typically be specified by default as directories for fontconfig. –  cfr Mar 11 at 2:00
    
@cfr: I have no clue about Linux and OS X, everything above regarding this is searched from other questions/answers or asked in chat. Feel free to add your remarks into the answer – or we let your comments stay as such. Or, other idea, add a second answer, you have doubtless a lot of insight (I will delete this comment later). –  Speravir Mar 11 at 2:17
    
I will come back to this when I've thought about it a bit... –  cfr Mar 11 at 2:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.