Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using the \usepackage[Bjornstrup]{fncychap}. The problem I encountered is shown in figure attachment. How can I fix it?

I tried changing the style file from:

409   \addtolength{\mylen}{-2\myhi}

to

409   \addtolength{\mylen}{1.7\myhi}

and it fixes the problem, but it is ugly and can potentially have side affects. Is  there a better way?

Using texlive 2012 on mac.

Update: I am using a template there I found that some settings in the margins might be causing this. Working example:

\documentclass[12pt,twoside]{book}
\usepackage[Bjornstrup]{fncychap}

\oddsidemargin 5mm
\evensidemargin 5mm
\textwidth 150mm
\topmargin 0mm
\headheight 0mm
\textheight 225mm

\begin{document}
\chapter{Chapter title}
lorem impsum.

\end{document}
share|improve this question
2  
Welcome to TeX.sx!. Please provide a minimal working example (MWE). A simple test of the code you post in the standard book class, does not demonstrate the problem you see. –  Andrew Swann Jan 3 '13 at 10:03
    
@AndrewSwann , thanks for reply. I updated the question with an example. I guess the problem is margin (\textwidth) settings in the template I use. –  user3232 Jan 3 '13 at 10:37
add comment

2 Answers

up vote 2 down vote accepted

Your immediate issue can be solved by changing \textwidth & friends before loading fncychap. However, in LaTeX documents based on the standard classes it is good practice to use the geometry package for modifying page margins; in your example I suggest

\documentclass[12pt,twoside]{book}

\usepackage[hcentering,textwidth=150mm,textheight=225mm]{geometry}

\usepackage[Bjornstrup]{fncychap}

\usepackage{lipsum}

\begin{document}

\chapter{Chapter title}

\lipsum

\end{document}
share|improve this answer
add comment

Found the solution. Just need to put the \textwidth before the package declaration. Fixed example:

\documentclass[12pt,twoside]{book}
\textwidth 150mm
\usepackage[Bjornstrup]{fncychap}

\oddsidemargin 5mm
\evensidemargin 5mm
\topmargin 0mm
\headheight 0mm
\textheight 225mm

\begin{document}
\chapter{Chapter title}
lorem impsum.

\end{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.