TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to write text in Russian language with some citations in Russian, English and German references using XeLaTeX + polyglossia + biblatex + biber. As a biblatex style I use biblatex-gost which processes multilingual bibliographies fine with usual LaTeX + babel + bibtex, but the results in XeLaTeX are not so good - all fields are not localized.

My .tex file:

\documentclass[11pt, a4paper]{article}


\setmainfont{Palatino Linotype}
\setmonofont{Courier New}


\setotherlanguages{english, german}


Some text \cite{Gonzalez2002,Gonzalez2005ru}.


thesis.bib file:

  title = {Digital Image Processing},
  publisher = {Prentice Hall},
  year = {2002},
  author = {R. C. Gonzalez and R. E. Woods},
  pages = {793},
  edition = {2},
  language = {english},
  hyphenation = {english}

  title = {Цифровая обработка изображений : Пер. с англ},
  publisher = {М.: Техносфера},
  year = {2005},
  author = {Р. Гонсалес and Р. Вудс},
  pages = {1072},
  language = {russian}

The result pdf looks like this:

but should:

I've read that biblatex cannot work with polyglossia (at least it was so some time ago), but I hope there is a possible solution and would be very grateful if anyone could help me.

UPD: As a TeX-system I use TeXLive 2012.

share|improve this question
The babel=other setting only works with babel loaded. A solution would require adding a polyglossia interface to biblatex. If you can't work with babel and xecyr, consider submitting a feature request. – Audrey Jan 10 '13 at 21:01
I get \edef\gostmedialanguage{russian} when I try to compile Your document. – Adobe May 20 '13 at 15:16
We have just submitted a potential fix for polyglossia support to the 2.8 DEV biblatex version on SF. Please try it and report any problems to the enhancement request here: github.com/plk/biblatex/issues/69 – PLK Sep 28 '13 at 13:00
Yes, great, thanks! Now it works. – darkled Nov 7 '13 at 16:53
up vote 4 down vote accepted

The authors should know better but as far as I know Biblatex does not officially support polyglossia (unfortunately). I use Babel with xecyr which seems to work fine, although I've not tested it thoroughly.

UPDATE: Polyglossia support has been added to Biblatex since ver.2.8.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.