Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use vim with with vim-latexsuite and TexLive. I use the .sty and .cls files, respectively the whole package date 2012-05-10 from the university of Hagenberg Link to zip package.

Till yesterday everything works like a charm which means that the document including the bibliography was build as intended.

Today I updated my notebook to vim 7.3, vim-latexsuite 20121118-1 and texlive 2012.28273-1.

I tried to compile my main file but the document doesn't either show a bibliography nor references in the text. I have no idea why the bibliography cannot be resolved.

I devided the information I have into two sections.

In section 1 I try to show the relevant parts of my main, [sty] and cls document.

In section 2 I try to show the relevant parts of the log files.

// Section 1 / main-file

\documentclass[bachelor,german]{hgbthesis}
\AddBibFile{literatur.bib}  % Angabe der BibTeX-Datei; is a wrapper for \addbibresource defined in .cls

\begin{document}

\include{cha1}
\include{cha2}

\MakeBibliography{Quellenverzeichnis}  %defined in .cls

\end{document}

/ .cls-file (hgbthesis.cls) - extract

\usepackage{csquotes}   % recommended for biblatex
\usepackage[style=numeric-comp]{biblatex}[2011/05/12]
\ExecuteBibliographyOptions{sortcites=true,defernumbers=true,isbn=false,doi=false}
\newcommand{\MakeBibliography}[2][]{
% opt. arg (#1): optional argument "nosplit" to get a 1-piece bibliography
% req. arg (#2): main title of bibliography
\clearpage
\ifthenelse{\equal{#1}{nosplit}}%
    {% create a single bibliography with all entries:
        \printbibheading[heading=bibintoc,title={#2}]
        \begin{bibhyphenation}  
        \printbibliography[heading=noheader]
        \end{bibhyphenation}
    }
    {% split the bibliography using the predefined categories:
        \printbibheading[heading=bibintoc,title={#2}]
        \begin{bibhyphenation}
        \printbibliography[filter=literature,heading=subbibintoc,title={\@bibtitleLiteratur}]
        \printbibliography[filter=avmedia,heading=subbibintoc,title={\@bibtitleAvmedia}]
        \printbibliography[filter=online,heading=subbibintoc,title={\@bibtitleOnline}]
        \end{bibhyphenation}
    }%

// Section 2

I did a backup of the whole directory thus I compared the aux file and had a look in to the .log and .blg file.

// .aux files / old - correct .aux file

\@writefile{lot}{\defcounter {refsection}{0}\relax }\@writefile{lot}
{\select@language{ngerman}}
\@input{cha1einleitung.aux}
\@input{cha1performanceMgt.aux}
\citation{MarStraPerfMgt}
\citation{MarStraPerfMgt}
\citation{ReiMktPerfMgt}
\citation{SchEntImpPerfMgt}
[...]
\abx@aux@number{140}{SchStratProjMgt}{0}{1}
\abx@aux@number{141}{ArmPerfMgt}{0}{2}
\abx@aux@number{142}{BarBSC}{0}{3}

/ new .aux file

\@writefile{lot}{\defcounter {refsection}{0}\relax }\@writefile{lot}   
{\select@language{ngerman}}
\@input{cha1einleitung.aux}
\HyPL@Entry{4<</S/D>>}
\abx@aux@cite{DilUntFuehrung}
\@input{cha1performanceMgt.aux}
\abx@aux@cite{MarStraPerfMgt}
\abx@aux@cite{ReiMktPerfMgt}
[...]

// new .log file shows the following message

LaTeX Warning: Citation 'MarStraPerfMgt' on page 4 undefined on input line 29.

// new .blg file shows this message

I found no \citation commands---while reading file cb_MainFile.aux
I found no \bibdata command---while reading file cb_MainFile.aux
I found no \bibstyle command---while reading file cb_MainFile.aux

Citations in my document look like this:

\autocite[some text]{book1}
share|improve this question

closed as too localized by lockstep, Martin Schröder, Seamus, Kurt, Claudio Fiandrino Jan 28 '13 at 12:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Have you tried to compile a very simple document with biblatex references, only to check whether the problem is in biblatex or in you complicated code? –  tohecz Jan 8 '13 at 22:29
1  
test with .tex and .bib,courtesy of andy-roberts.net –  texenthusiast Jan 8 '13 at 22:35
1  
Do you process the bib file with bibtex or biber. Newer versions of biblatex use biber as default backend. –  Guido Jan 9 '13 at 8:09
    
As Guido says, the present version of biblatex uses Biber as default backend for generating the .bbl file; you probably are still using BibTeX. I don't know how to persuade Vim to call Biber, but you can do it from the command line: biber filename as usual –  egreg Jan 9 '13 at 9:48
    
I compiled a sample doc (from texenthusiast) as tohecz advised. Worked fine. I think the reason for the error occured because the backend to biblatex changed as Guido supposed. This line changed to: \usepackage[style=numeric-comp,backend=bibtex8]{biblatex}[2011/05/12] ---- I'm aware that I should vote for comments and answers but although I'm registered it is not possible. –  clementis Jan 9 '13 at 16:09