Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was trying to include bibliography in my presentation. But when I try to include bibliography I get this error:

! Undefined control sequence.
\beamer@sort #1#2->\long \def \beamer@todo 
                                           {#1}\def \beamer@ospec {}\beamer@...

I get this error when I run pdflatex second time, the first run completes with no errors and references appear in the bibliography.

My bibliography looks like this:

\begin{frame}
  \frametitle{References}
  \begin{thebibliography}{nevell1984unified}
    \bibitem[Bandaru and Deb, 2010]{deb10}
      Bandaru, S. and Deb, K. (2010).
      \newblock Automating discovery of innovative design principles through
      optimization.
      \newblock Technical Report 2010001, Kanpur Genetic Algorithms Laboratory,
      Indian Institute of Technology, Kanpur.

    \bibitem[Anderson, 1996]{anderson96}
      Anderson, J. (1996).
      \newblock {\em {The architecture of cognition}}.
      \newblock Lawrence Erlbaum.

  \end{thebibliography}
\end{frame}

I have unsuccessfully tried using bibtex to generate the bibliography but I keep getting equally strange errors, like \newblock unrecognized or \item missing from list environment etc, no matter what I do. If I remove the bibliography, everything works fine apart from the unknown citations warnings. Is there a simple working way to include the bibliography in beamer?

share|improve this question
2  
I'm able to compile this frame in a beamer presentation without problems. Please post a minimal example which produces that error. –  Stefan Kottwitz Jan 16 '11 at 13:09
    
Nevermind, I located the problem, it was the \uspackage{cite} in my preamble. After commenting it everything is working fine. Thanks. –  Dronacharya Jan 16 '11 at 13:40
1  
which is why it's always a good idea to try to produce a minimal example before asking a new question. Anyway, you could post your comment as an answer and accept it, so that this question doesn't remain unanswered. –  Juan A. Navarro Jan 16 '11 at 13:54
    
@Juan: I will keep in mind. I can accept my answer only after 2 days. Thanks. –  Dronacharya Jan 16 '11 at 15:54
add comment

1 Answer 1

up vote 3 down vote accepted

I located the problem, it was the \usepackage{cite} in my preamble. After commenting it everything is working fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.