Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I wish to compile my dissertation in the beautiful classicthesis. My setting: Mac OX 10.6.8, TeX Live 2012 + LyX 2.0.5. I am able to work and produce document in Chinese elsewhere including in book, memoir, but just not in classicthesis. After several attempts, including copying following solution... http://www.latex-community.org/forum/viewtopic.php?f=40&t=11098 Maybe the problem is on babel that doesn't accommodate Chinese? I wonder if anyone can provide a direction for solving this issue.

share|improve this question
    
\usepackage{ctex}, then it can produce Chinese words. Why not use pkuthss,seuthesis or thuthesis? They are all thesis templates for Chinese. –  Pig Cry Jan 10 '13 at 4:11
    
Thank you for the kind suggestion, Pig Cry. I got the problem solved. It didn't go with \usepackage{ctex}, but with {pinyin}{babel}. –  user24219 Jan 10 '13 at 6:02
2  
@user24219 I'm interested in using classicthesis, and I also use Chinese text; would you mind writing out the full solution for the problem? –  Mårten Jan 10 '13 at 8:05

1 Answer 1

step 1: find -config.tex and make following change. {latin9}{inputenc}{utf8}{inputenc}. {ngerman,american}{babel}{pinyin,american}{babel}. plus adding \usepackage[pinyin]{babel}. step 2: go to each document and perform lyx document setting→fonts/cjk/bsmi(or others). then →language: chinese(...), encoding: language default. modules should be selected accordingly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.