Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have the following error:

(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.sty
(/usr/share/texlive/texmf-dist/tex/generic/babel/english.ldf
(/usr/share/texlive/texmf-dist/tex/generic/babel/babel.def))
(/usr/share/texlive/texmf-dist/tex/generic/babel/germanb.ldf)
(/usr/share/texlive/texmf-dist/tex/generic/babel/english.ldf
*************************************
* Local config file english.cfg used
*
(/usr/share/texlive/texmf-dist/doc/support/pedigree-perl/examples/english.cfg
! You can't use `macro parameter character #' in vertical mode.
l.1 #
      An example configuration file for pedigree program

? 

Unfortunately, I can not give an minimal example.

This error appeared after I updated to TeX Live 2012/Debian (I am using Linux Mint 14). Before that the documents that now produce the error could be compiled.

I am wondering why this file is looked at at all. Has anyone experienced the same? Or has anyone an idea how to get ride off this error?

share|improve this question
    
That path should not hashed: I have the same file on my system ('vanilla' TL, Windows 7), but it does not interfere with anything. –  Joseph Wright Jan 11 '13 at 8:43
2  
Are you loading anything in relation to pedigree-perl in your document? AFAIR usually TL does not load anything from the doc three. Besides, it is not a LaTeX file, so it would be nice to figure out why it is loaded in your document. What does kpdewhich english.cfg say? I do not get any results –  daleif Jan 11 '13 at 9:34
4  
Babel tries to load <language>.cfg if existent. You probably have added texmf-dist/doc/support/pedigree-perl/examples to the TEXINPUTS variable in order to access the .csv files there, so babel finds english.cfg and wants to load it, but it's not a TeX file. –  egreg Jan 11 '13 at 10:23
    
@egreg Ahh, I was looking for that one, but forgot to look inside babel.def –  daleif Jan 11 '13 at 10:27
    
egreg you are right. I just put /usr/share// in TEXINPUTS. What should i put in there? –  Jana Jan 11 '13 at 11:05
show 1 more comment

1 Answer

up vote 1 down vote accepted

You have in your TEXINPUTS path a file called english.cfg; such a file is indeed existent in <TeX-root>/doc/support/pedigree-perl/examples, but it's a Perl file.

The doc subtree should never be added to the TeX search paths. Setting

export TEXINPUTS=/usr/share//:

is definitely a bad idea. There's usually no need to set the variable.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.