Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How can I tell LyX to put page numbers in the rendered PDF?

I looked in all the menus, and haven't find the correct option.

The closest matches are: Document -> Settings -> Page Layout, or Document -> Settings -> Numbering, but none of them has page numbering.

--

Here is my first try to post a MWE:

#LyX 2.0 created this file. For more info see http://www.lyx.org/
\lyxformat 413
\begin_document
\begin_header
\textclass article_acl_singlecolumn
\use_default_options true
\maintain_unincluded_children false
\language english
\language_package default
\inputencoding auto
\fontencoding global
\font_roman default
\font_sans default
\font_typewriter default
\font_default_family default
\use_non_tex_fonts false
\font_sc false
\font_osf false
\font_sf_scale 100
\font_tt_scale 100

\graphics default
\default_output_format default
\output_sync 0
\bibtex_command default
\index_command default
\float_placement h
\paperfontsize 11
\spacing single
\use_hyperref false
\papersize a4paper
\use_geometry true
\use_amsmath 1
\use_esint 1
\use_mhchem 1
\use_mathdots 1
\cite_engine natbib_authoryear
\use_bibtopic false
\use_indices false
\paperorientation portrait
\suppress_date false
\use_refstyle 1
\index Index
\shortcut idx
\color #008000
\end_index
\secnumdepth 3
\tocdepth 3
\paragraph_separation indent
\paragraph_indentation default
\quotes_language english
\papercolumns 1
\papersides 1
\paperpagestyle fancy
\tracking_changes false
\output_changes true
\html_math_output 0
\html_css_as_file 0
\html_be_strict false
\end_header

\begin_body

\begin_layout Title
No Page Numbers Example
\end_layout

\end_body
\end_document
share|improve this question
    
Can you please post a MWE (minimum working example) .lyx file? –  scottkosty Jan 13 '13 at 10:05
    
Not sure how to do it, but I tried - I left only the title –  Erel Segal Halevi Jan 13 '13 at 10:09
    
I don't have your document class so I can't work with this. Everything works fine if you change your document class to Article (Standard Class) in Document > Settings > Document Class. I imagine that this is not what you want though. –  scottkosty Jan 13 '13 at 10:23

2 Answers 2

up vote 1 down vote accepted

It depend of the document class that you have selected (by default is article) in Document > Configuration. Make a new simple document (only with some words) and make the PDF: the number of is showed by default centered at the footer. If you change the document class to book the number of page will be in the top right in a beamer class is not showed ... and so on.

I do not have your document class but I changed this in your file:

\textclass article_acl_singlecolumn

by

\textclass article

to have the standard class article, and it show the number of page without problem.

Moreover, this can be modified by header and footer settings in Page layout or wih LateX code in the preamble. To understand how this work, read about the fancyhdr LaTeX package.

In any case, you can insert the number of page also in any part of the body document inserting a ERT box (Ctrl+L) with the code \thepage.

share|improve this answer
Document -> Settings -> Page Layout -> Pagestyle

should not be set to empty amd there should also not a \pagestyle{empty} in your preamble.

share|improve this answer
    
In Document -> Settings -> Page Layout, I don't have pagestyle. I only have Format (which I set to "A4"), Orientation (which I set to "Portrait"), Heading style (which I set to "plain"), and Two-sided document checkbox (which is unchecked). –  Erel Segal Halevi Jan 13 '13 at 9:28
    
About the preamble - how do I see it? –  Erel Segal Halevi Jan 13 '13 at 9:28
    
@ErelSegalHalevi Document > Settings > LaTeX Preamble –  scottkosty Jan 13 '13 at 10:23
    
"Document > Settings > LaTeX Preamble" shows an empty box. –  Erel Segal Halevi Jan 13 '13 at 12:20
    
@ErelSegalHalevi: It is the lower field in the page layout setting, not the upper one for paper size. –  Herbert Jan 13 '13 at 12:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.