Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
Automatically convert quotations in the form of “abc” to become ``abc"

My quotes are coming up like end quotes on both sides of the quotation. How can I overcome this?

Here is my code and it works fine on this writer just on my Texmaker the problem happens. Could it be my keymapping or something like this?

%----------------------------------------------------------------------------------------
%   PACKAGES AND OTHER DOCUMENT CONFIGURATIONS
%----------------------------------------------------------------------------------------

\documentclass[paper=a4, fontsize=11pt]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel} % English language/hyphenation
\usepackage{amsmath,amsfonts,amsthm} 
\usepackage[super,comma,sort&compress, square]{natbib}

\begin{document}
\title{}

\maketitle % Print the title

Some sort of "quotation"

\bibliography{mybib}
\bibliographystyle{unsrt}

\end{document}
share|improve this question

marked as duplicate by hpesoj626, Guido, Werner, Martin Schröder, Andrew Swann Jan 14 '13 at 8:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
What other editor are you using? Version 2.5.1 of TeXStudio the TeXMaker fork has Replace double quotes feature. I don't think this is present in Texmaker yet. The following are possibly duplicate posts: tex.stackexchange.com/questions/50712/… and tex.stackexchange.com/questions/52351/… –  hpesoj626 Jan 14 '13 at 3:54
    
I have added \begin{document} in your code to make it compilable. I hope you don't mind. :) –  hpesoj626 Jan 14 '13 at 3:56
    
@hpesoj626 not at all. Thanks I am not sure which maker it is to be honest. It's whichever the one in the repository from ubuntu 12.10 is. A big buggy actually. Also I think the `\begin{document} should go after the \title{} preamble shouldn't it? –  Magpie Jan 14 '13 at 6:42
    
I don't know if we understand each other. So you are saying that you are using another version of Texmaker? I was asking if you are using another editor apart from Texmaker. As to where to put the \title{} command, I've seen as many cases where it is written in the preamble as it was written after \begin{document}. Perhaps we can ask as a separate post. Although I've seen some custom classes that throws errors when it is not written in the preamble and some custom classes that throws errors when it is not written after \begin{document}. That said, I don't think I have an answer. –  hpesoj626 Jan 14 '13 at 7:03

1 Answer 1

up vote 7 down vote accepted

You should use two backticks

`

and two

' to get correct quotes as in

``quotation''.

Or a better option would be to use csquotes package with option

 \usepackage[autostyle=true]{csquotes}

as you are using babel.

\documentclass[paper=a4, fontsize=11pt]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel} % English language/hyphenation
\usepackage{amsmath,amsfonts,amsthm}
\usepackage[super,comma,sort&compress, square]{natbib}
\usepackage[autostyle=true]{csquotes}
\begin{document}
\title{}
\maketitle % Print the title

Some sort of ``quotation'' \enquote{quotation}

\bibliography{mybib}
\bibliographystyle{unsrt}

\end{document}

enter image description here

For details on csquotes refer to documentation which you can get by running texdoc csquotes or at www.texdoc.net.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.