Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

picture of the problem

For most of the chapters in my document, LaTeX lays out the text wonderfully. The text goes right down to the page number.

However, for a few of the chapters, I have the problem pictured above.

The chapter is cut off early in the page, and one or two words are placed on the next page, whereas,what I would like is for the chapter to end on the last page and for a new chapter to start anew on the next page.

This is my document class declaration:

\documentclass[12pt, oneside, openany, draft, article ]{memoir}

How can I fix this problem?

share|improve this question
1  
As this shouldn't really happen having a full MWE that reproduces the problem would be very helpful. –  StrongBad Jan 14 '13 at 10:55
    
What happens without the article option? Does the chapter start on a new page? How to avoid widows is explained in the TeX FAQ. –  sebschub Jan 14 '13 at 11:11
    
Right. I knew there must be a name for the problem: widows. –  Paul Jan 14 '13 at 11:17
    
@sebshub If I get rid of the article option, other things happen that I don't want. The link indicates that widows are a tricky problem. I have tried, I think all of the options listed in the link to no avail. Update: I seem to have solved the problem with \newpage. –  Paul Jan 14 '13 at 11:30
    
The post tex.stackexchange.com/questions/9497/… answers the question how to start a new section on a new page. You could apply this for chapters. –  Jana Jan 14 '13 at 13:51

1 Answer 1

Without having access to the code that generates the problem you're reporting, it's not possible to give a definitive diagnosis or remedy. From what you're showing us, I can think of two phenomena causing the problem:

  • It could be the case that your document currently doesn't control typographic widows and orphans sufficiently. If that's the case, setting \widowpenalty10000 in the preamble should solve your problem.

  • If, on the other hand, it's a matter of the penultimate page of a chapter being too short by exactly one line, increasing the widow penalty parameter will only end up forcing 2 lines, rather than just 1 line, being shown on the final page. Not much of an improvement, right?! If that's the case, you're better off issuing the directive

    \enlargethispage{1\baselineskip}
    

    just before the final paragraph of the chapter. By the way, if you're using single-spaced text, 1\baselineskip should be the correct amount. If, per chance, you're double-spacing the lines, something like 1.7\baselineskip would be more appropriate.

    Fine-tuning the size of the text block is something that should be left to the very end of the process of creating a document. Otherwise, you'll find yourself fiddling endlessly with these matters. Incidentally, you may also find that rather than enlarging the height of the text block, you (and the readers of your document!) may be better served if you shorten the text here and there so that it naturally ends up taking up less space, making enlarging the height of the text block unnecessary from the get go.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.