Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the llncs document class and wanted to change the margin of all pages, using the geometry package.

I use the following command:

\usepackage[left=3.5cm,right=2.5cm,top=2.5cm,bottom=2.5cm]{geometry}

The problem is that the left margin is switching between odd and even pages. Even numbered pages have the 'left' margin on the right side and the odd numbered pages have the 'left' margin on the actual left side.

I don't know if this is a problem with llncs or geometry (thus, the title could be misleading), but how would I tell my document to have the left margin on the actual left side, for every page?

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

The llncs class loads the article class with the twoside option and doesn't have a oneside option. You can revert back to "oneside" by switching manually:

\makeatletter
\let\@twosidetrue\@twosidefalse
\let\@mparswitchtrue\@mparswitchfalse
\makeatother

\documentclass{llncs}
\usepackage[left=3.5cm,right=2.5cm,top=2.5cm,bottom=2.5cm]{geometry}
share|improve this answer
    
Ah! I see. I changed it directly in the llncs.cls file now. –  cherrung Jan 14 '13 at 18:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.