Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use biber with backref, but backref points to a wrong page. Option backref always gets it one page wrong.

Why does it so and how can I solve the problem?

Here's what might be related to the problem:

\usepackage[backend=biber,backref,style=authoryear,isbn=false,dashed=true]{biblatex}

\usepackage[%
  colorlinks,urlcolor = black,pdfpagelabels,pdfstartview = FitH,
  bookmarksopen = true,bookmarksnumbered = true,linkcolor = black,
  plainpages = false,hypertexnames = false,citecolor = black
]{hyperref}

\thispagestyle{empty}
\tableofcontents
\clearpage
%start counting afresh after toc
\setcounter{page}{2}
share|improve this question
5  
Please give a complete MWE. Your code works for me. So, there must be something else in your document. –  Guido Jan 15 '13 at 11:11
    
Instead of resetting the page counter: What do you think about using \pagenumbering{roman} (or Roman or alph or Alph) for the frontmatter and \pagenumbering{arabic} after the \clearpage for the mainmatter, using the hyperref package with option plainpages=false, and in Adobe Reader Edit > Preferences > Page Display > Page Content and Information > Use logical page numbers (or the equivalent in your preferred PDF viewer)? –  Stephen Jan 16 '13 at 20:46
    
@Stephen: That sounds like a good option! I would totally consider choosing it as the best answer, if only it was one... –  Martin Betz Jan 16 '13 at 20:49
    
OK, posted as answer. Glad if it helps you. –  Stephen Jan 17 '13 at 11:25
add comment

1 Answer 1

up vote 1 down vote accepted

This does not answer why backref refers to the wrong page, but it could be a solution to your problem nevertheless.

Do not reset the page counter manually but use different page numberings:

  • \pagenumbering{roman} (or Roman or alph or Alph) for the frontmatter, possibly with a pagestyle not printing the page number at all if you do not like it. (You already use \thispagestyle{empty}, \pagestyle{empty} could be used.)
  • \pagenumbering{arabic} after the \clearpage (for two-sided documents: cleardoublepage) for the mainmatter

Give the option plainpages=false to the hyperref package, so that hyperref treats for example page ii and 2 as different pages. (You already did this in your example, I just wanted to explicitly mention it for possible other users faced with a similar problem.)

When you use in Adobe Reader Edit > Preferences > Page Display > Page Content and Information > Use logical page numbers (or the equivalent in your preferred PDF viewer), it will show the page "name" and the number of the page. For example with 10 pages with names i to x in the frontmatter, page "5" is the 15th page and the reader shows "5 (15 of ...)", where "..." is the total number of pages. This also has the advantage that entering "5" there indeed takes you to the page named "5" and not to the fifth page (named "v").

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.