Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use the microtype package as illustrated in this page: http://texblog.net/latex-archive/layout/pdflatex-microtype/.

But I am getting this output instead:

faulty output

So any ideas why this is happening?

Here is the code as requested:

\documentclass[a4paper,10pt]{article}
\usepackage[english]{babel}
\usepackage{blindtext}
\usepackage{microtype}
\begin{document}
\begin{minipage}{3.7cm}
\blindtext
\end{minipage}
\end{document}

EDIT1: I just realize that there are some small literal differences between the blindtext output that I got and the blog's one. For example instead of what in the third line, there is a how. I am going to change my blindtext to match the blog's copy to see if there is some improvement.

EDIT2: Here are the result after I enabled \frenchspacing and made the blindtext corrections. Note that in the blog's example the "a" should be one line above its current position.

updated faulty output

EDIT3: I updated my microtype package to version 2.5 beta-07 but I got no drastic changes.

share|improve this question
1  
With \textls[-9]{\blindtext} you will get it away. But then later you will get more white space. For such narrow columns it is always better to use \raggedright (or for special cases \raggedleft) – and much, much better to load the package ragged2e and use then \RaggedRight (or \RaggedLeft). –  Speravir Jan 16 '13 at 3:55
    
I get the same output as in the blog. Which version of microtype do you use? Is there any warning in the .log file? Finally, which version of pdflatex are you using? –  mafp Jan 16 '13 at 10:44
    
@mafp I am using pdflatex version 3.1415926-2.4-1.40.13 and microtype version 2.4. I am not sure (since i just started to use Latex) but I didn't notice anything unnusual in the .log file –  Pedro Dreyer Jan 16 '13 at 11:27
    
I use microtype-2.5-beta07, but since you have a different text, this probably is the reason. –  mafp Jan 16 '13 at 11:58
4  
The default LaTeX behaviour is that it doubles the spacing after a period. This is what's causing the large spacing. If you enable \frenchspacing LaTeX will insert a normal space after the period. When I enabled \frenchspacing and compiled your example it solved the probelm. –  Marc van Dongen Jan 16 '13 at 12:08

1 Answer 1

It looks to me that there is an error on the blog and the original run done when the screen capture was taken was at a slightly wider minipage, possibly at 3.9cm or the microtype defaults file is different.

For very narrow columns, you are normally better off with the ragged2e package. Compare with this:

\documentclass[a4paper,10pt]{article}
\usepackage[english]{babel}
\usepackage{blindtext}
%\usepackage{microtype}
\usepackage{ragged2e}
\begin{document}
\begin{minipage}{3.4cm}
\blindtext
\end{minipage}
\end{document}
share|improve this answer
    
I get the same output as in the blog, so something different is going on here. –  mafp Jan 16 '13 at 10:45
    
@mafp As mentioned, possibly the version of the defaults file. –  Yiannis Lazarides Jan 16 '13 at 10:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.