Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a paper written and edited in LyX.

On a printing today I noticed that all 'fi' combinations are not visible.

The characters are in the document and displays in the PDF but doesn't print.

Is this a printer, LyX or PDF problem?

share|improve this question
    
Ok. Interesting bit. On using pdflatex to create the final document, the 'fi' as in beneFIts displays correctly. On printing though the characters go missing. –  Forkrul Assail Jan 21 '11 at 12:09
    
On exporting to PS and directly printing the .ps file, everything works fine. I can print my docs now, but would be interesting to solve this puzzle. Bug in pdflatex? –  Forkrul Assail Jan 21 '11 at 12:09
5  
Sounds like a font problem: one of your ligatures has gone walkabout... –  Seamus Jan 21 '11 at 12:13
2  
Can you see if the fonts are embedded? If you have access to Xpdf, the pdffonts utility will tell you which fonts are embedded. –  Charles Stewart Jan 21 '11 at 14:46
2  
@Forkrul: that is a default behaviour, when your embedded fonts have no ligatures. Which font setting do you have? Convert your LyX document to latex and look at the beginning of the source. –  Herbert Feb 6 '11 at 18:43

1 Answer 1

up vote 4 down vote accepted

This is a font problem, but might be also related to your printer/its driver.

The 'fi' character (+ 'ff', 'fl', ...) is a ligature, i.e. a combination of two characters created to optimize the space between the characters. Some fonts do not include these special characters and they also tend to go missing in conversions. Your printer driver might convert the PDF to Postscript for printing and something gets messed out at this point. Maybe your font is not Postscript compatible. Should you load any kind of font packages try to disable them and see if the print-out changes.

You should also ensure that you use the font with a proper encoding, e.g. by loading:

 \usepackage[T1]{fontenc}

in the preamble.

You might try to use another (at best PostScript) fonts which have the ligatures included. Some possible choices would be psnfss (Postscript New Font Selection Scheme), pxfonts (Palatino style) or txfonts (Times style). Simply load them like packages, e.g. \usepackage{psnfss}.

The ligatures can also be disabled globally using: (needs pdflatex)

\usepackage{microtype}
\DisableLigatures{encoding=*,family=*}
share|improve this answer
2  
One should add that disabling the ligatures is strongly discouraged. The handling of ligatures is one of TeX's achievements. –  Hendrik Vogt Feb 7 '11 at 9:05
    
Yes @Hendrik I should have mentioned that. That's also the reason I'm first suggested changing the font. Unfortunately many people are used to MS Word documents and will not even see ligatures, and if they do normally think it is a print error :-( –  Martin Scharrer Feb 7 '11 at 9:10
    
\DisableLigatures also disables en-dashes (--) and em-dashes (---). Workaround: tex.stackexchange.com/questions/57718/ligatures-disabling –  marcin Jul 7 at 11:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.