Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have the following problem. My .tex file (see below) works in MacTeX 2011 without problems (build it using XeLaTeX => BibTeX => XeLaTeX). After I updated from MacTeX 2011 to MacTeX 2012 it doesn't work. During build I get the following error in console.

This is BibTeX, Version 0.99d (TeX Live 2012)
The top-level auxiliary file: ABook.aux
I found no \citation commands---while reading file ABook.aux
I found no \bibdata command---while reading file ABook.aux
I found no \bibstyle command---while reading file ABook.aux
(There were 3 error messages)

My .tex file is the following :

% !TEX TS-program = xelatex
% !TEX encoding = UTF-8 Unicode
\documentclass[a4paper,12pt,two side,titlepage]{scrbook}
\usepackage{xltxtra}
\usepackage{fontspec}
\usepackage{polyglossia}
\setdefaultlanguage{german}
\usepackage{xunicode}
\usepackage{metalogo}       
\usepackage{unicode-math}
\usepackage{amsmath}
\setmainfont{TeX Gyre Pagella}
\setmathfont{Palatino}
\usepackage[autostyle=true]{csquotes}
\usepackage[natbib=true,style=authoryear]{biblatex}
\newcommand*{\annotecite}[1]{\citefield{#1}{annotation} \autocite{#1}}
\bibliography{NaWiLibrary}
\begin{document}
\enquote{\annotecite{MikrobiologieBrock}}
\printbibliography
\end{document}

My example entry in the .bib (BibTeX) file is the following :

@book{MikrobiologieBrock,
    Annote = {Kapitel 1, Seite 8, Zusammenfassung ... 
},
    Author = {Michael T. Madigan, John M. Martinko},
    Date-Added = {2012-11-10 13:55:04 +0000},
    Date-Modified = {2012-11-14 08:59:46 +0000},
    Edition = {11., aktualisierte Auflage 2009},
    Isbn = {978-3-8273-7358-8},
    Pages = {1248},
    Publisher = {Pearson Studium},
    Title = {Brock Mikrobiologie},
    Url = {http://www.pearson-studium.de/main/main.asp?page=bookdetails&ProductID=169347},
    Year = {12 / 2008},
    Bdsk-Url-1 = {http://www.pearson-studium.de/main/main.asp?page=bookdetails&ProductID=169347}}

Has someone a idea how to fix this ?

share|improve this question
    
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Upvoting is the preferred way here to say "thank you" to users who helped you. –  Guido Jan 18 '13 at 6:24
add comment

1 Answer 1

up vote 3 down vote accepted

With MacTeX 2012 you have a recent version of biblatex (version > 2.0), while in MacTeX you have a version < 2.0. With with a version of biblatex > 2.0 the default backend is biber and no longer bibtex. Thus you have two options, compile the bibliography with biber or add backend=bibtex to the option of biblatex.

share|improve this answer
    
Thanks that was the solution. I found no detail informations because the texdoc biblatex command in terminal brings the pdf of version 1.6. Only if you look in the TeX Live Utility you get the pdf of version 2.5. I decided to use backend=bibtex and changed the line to \usepackage[backend=bibtex,natbib=true,style=authoryear]{biblatex}. –  NaWi at Mac Jan 18 '13 at 9:34
    
@NaWiatMac you can use texdoc -l bib latex.pdf to list all versions of the pdf. You might have an old version of biblatex somewehre in your TeX environment. –  Guido Jan 18 '13 at 10:41
    
Nope, there is no other file because it was a clean install on a new MacBook with Mountain Lion. After I used texdoc biblatex again, I saw in Preview that the translation (I run a german system) was opened. texdoc -l biblatex-de.pdf and texdoc -l biblatex.pdf show´s me that the biblatex.pdf was version 2.5 and the biblatex-de.pdf was version 1.6. I reported that by email to the MacTeX team. –  NaWi at Mac Jan 18 '13 at 20:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.