Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Maybe it is just me (I don't think so, though), but the placement of the diacritic marks in the otherwise wonderful Linux Libertine fonts is quite at odds with any well-informed typographic sensibility. Please do not take my remarks in a derogatory sense, since my intention is just stressing what I think is a most significant blunder which should be corrected -- and I don't think the correction means too much work.

Try compiling with pdfLaTeX the following MWE:

\documentclass{memoir}
\usepackage[mono,semibold]{libertine}

\def\vowels{\'a\'e\'i\'o\'u}

\begin{document}
Testing diacritic marks with Linux Libertine and Biolinum Type1:
\par\vowels
\par\textsc{\vowels}
\par\texttt{\vowels}
\end{document}

The issue is twofold and appears more clearly in the small caps and monospaced families: too large a vertical shift -- which is even sharper in the monospaced family -- and having the marks centered on the same vertical axis as the base glyphs, while they should be shifted rightwards. Just take a look at MinionPro or another good typeface design of your own choice and check the difference.

My intention is to bring this to the attention of the TeX community in order to see if there are other people who agree on my judgment and this can be fixed... unless it turns out to be just some issue of my own system.

share|improve this question
    
it might have something to do with the version of libertine you are using. Because here, neither libertine-type1, nor libertine-legacy has a mono option. –  mafp Jan 18 '13 at 13:01
    
Have you seen the related question MiKTeX 2.9 libertine suddenly broken? –  Kurt Jan 18 '13 at 13:13
    
The package is called simply libertine. It is the most recent version -- or so I believe, since it is dated January 2013. The related question doesn't seem to have anything to do with mine. Your comments are welcome, though. –  Marcos Jan 18 '13 at 14:23
1  
It's a problem in the font design. –  egreg Jan 19 '13 at 10:21
1  
The horizontal issue is in the design. The vertical issues are likely from the way the accented characters are composed by otftotfm, but possibly because some font parameters are incorrect. –  user22108 Jan 19 '13 at 21:17
show 5 more comments

1 Answer

up vote 1 down vote accepted

You can workaround the problem with

\usepackage[T1]{fontenc}

or by using xelatex or lualatex.

share|improve this answer
    
Your approach solves the issue about the vertical shift when using the Type1 encoding, which is my case since I'm compiling with pdfLaTeX. Nonetheless, there is still a problem about the horizontal alignment which should be corrected. This is the reason why I'm not sure about taking your answer as the right one even though it's been very useful. By the way, do you know why it is that by loading the fontenc package the marks are placed in a more appropriate location? –  Marcos Jan 19 '13 at 1:08
    
The horizontal alignment seems to be the same when the OpenType fonts are used (xelatex or lualatex); if you don't like it, complain to the designer (linuxlibertine.org). –  user22108 Jan 19 '13 at 1:42
2  
The default encoding is OT1, which doesn't have accented characters as single glyphs. In the T1 (or LY1) encodings, the accented glyphs in the font can be used. –  user22108 Jan 19 '13 at 1:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.