Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm working on my thesis because I have to hand it in just a few days. As many others I do the bibliography at the last minute.

Using Google a lot, I found various code-snippets, which make the bibliography look like I want it. The only problem is, that there are no editors shown in the incollection entries. They are replaced by a hyphen or something.

Here is what I got so far:

\documentclass[12pt, a4paper, titlepage, fleqn]{scrartcl}

\usepackage{graphicx}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
\usepackage[babel,german=quotes]{csquotes}

\usepackage{ccaption}
\captionstyle{\raggedright}

\usepackage[printonlyused]{acronym}
\renewcommand{\bflabel}[1]{\normalfont{\normalsize{#1}}\hfill}

\usepackage{setspace}
\onehalfspacing
\emergencystretch 1.5em

\usepackage{geometry}
\geometry{a4paper, top=20mm, left=30mm, right=30mm, bottom=20mm}

%%%%%%%%%%%%%% BIBLATEX %%%%%%%%%%%%%%%%%%%%%%%
\usepackage[
style=authoryear-icomp, 
maxbibnames=9, 
maxcitenames=2, 
uniquelist=false,
backend=biber]{biblatex} 

\DeclareFieldFormat{booktitle}{#1\isdot}
\DeclareFieldFormat{journaltitle}{#1\isdot}
\DeclareFieldFormat{issuetitle}{#1\isdot}
\DeclareFieldFormat{maintitle}{#1\isdot}
\DeclareFieldFormat{pages}{#1}
\DeclareFieldFormat{title}{#1\isdot}
\DeclareFieldFormat[article]{title}{#1}
\DeclareFieldFormat[inbook]{title}{#1}
\DeclareFieldFormat[incollection]{title}{#1}
\DeclareFieldFormat[inproceedings]{title}{#1}
\DeclareFieldFormat[patent]{title}{#1}
\DeclareFieldFormat[thesis]{title}{#1}
\DeclareFieldFormat[unpublished]{title}{#1}

\renewcommand*{\UrlFont}{\normalfont}
\renewcommand*\mkbibacro[1]{#1}

\DeclareBibliographyDriver{incollection}{%
\usebibmacro{bibindex}%
\usebibmacro{begentry}%
\usebibmacro{author/translator+others}%
\setunit{\labelnamepunct}\newblock
\usebibmacro{title}%
\printlist{language}%
\usebibmacro{in:}%
\usebibmacro{editor+others}% Herausgeber (Hrsg.) statt hrsg. von Herausgeber
\setunit{\labelnamepunct}\newblock%
\usebibmacro{maintitle+booktitle}%
\newunit\newblock
\printfield{edition}%
\newunit
\iffieldundef{maintitle}
{\printfield{volume}%
\printfield{part}}
{}%
\newunit
\printfield{volumes}%
\newunit\newblock
\usebibmacro{series+number}%
\newunit\newblock
\printfield{note}%
\newunit\newblock
\usebibmacro{publisher+location+date}%
\newunit\newblock
\usebibmacro{chapter+pages}%
\newunit\newblock
\iftoggle{bbx:isbn}
{\printfield{isbn}}
{}%
\newunit\newblock
\usebibmacro{doi+eprint+url}%
\newunit\newblock
\usebibmacro{addendum+pubstate}%
\setunit{\bibpagerefpunct}\newblock
\usebibmacro{pageref}%
\usebibmacro{finentry}} 


%\DeclareNameAlias{sortname}{last-first}
\DefineBibliographyStrings{ngerman}{andothers={et \addabbrvspace al \adddot}} 

%Blockzitat
\usepackage{setspace}
\renewenvironment{quote}
{\list{}{\rightmargin\leftmargin\singlespacing\footnotesize}%
\item\relax}
{\endlist} 

\addbibresource{Bibliographie.bib}
\newcommand*\dummy[1]{}

\begin{document}

\nocite{*}
\printbibliography

\end{document}

And this is one of my bibliography entries ... for testing.

@INCOLLECTION{ang2006,
author = {Ien Ang},
year = {2006},
title = {Radikaler Kontextualismus und Ethnografie in der Rezeptionsforschung.},
editor = {Andreas Hepp and Rainer Winter},
booktitle = {Kultur – Medien – Macht.},
location = {Wiesbaden},
publisher = {VS Verlag für Sozialwissenschaften.},
pages = {61-79},
owner = {SpecialGuest},
timestamp = {2012.11.12}
}

I really would appreciate any help on that.

EDIT:

Run the script with the following bib-file entries, and you will be able to reproduce the behaviour:

@INCOLLECTION{ang2006,
author = {Ien Ang},
year = {2006},
title = {Radikaler Kontextualismus und Ethnografie in der Rezeptionsforschung.},
editor = {Andreas Hepp and Rainer Winter},
booktitle = {Kultur – Medien – Macht.},
location = {Wiesbaden},
publisher = {VS Verlag für Sozialwissenschaften},
pages = {61-79},
owner = {SpecialGuest},
timestamp = {2012.11.12}
}

@INCOLLECTION{grossberg2006,
author = {Lawrence Grossberg},
year = {2006},
title = {Der Cross Road Blues der Cultural Studies.},
editor = {Andreas Hepp and Rainer Winter},
booktitle = {Kultur - Medien - Macht. Cultural Studies und Medienanalyse. 3.,
berarbeitete und erweiterte Auflage.},
location = {Wiesbaden},
publisher = {VS Verlag für Sozialwissenschaften},
pages = {23-40},
owner = {SpecialGuest},
timestamp = {2012.10.04}
}

@INCOLLECTION{grossberg1999,
author = {Lawrence Grossberg},
year = {1999},
title = {Was sind Cultural Studies?},
editor = {Karl H. Hörning and Rainer Winter},
booktitle = {Widerspenstige Kulturen. Cultural Studies als Herausforderung.},
location = {Frankfurt a. M.},
publisher = {Suhrkamp},
pages = {43-83},
owner = {SpecialGuest},
timestamp = {2012.10.04}
}

The editors are only shown in the Ang (2006) entry. In the other entries they are replaced by the - singn. I don't understand why BibLaTex behaves like that, but I have to turn in my thesis in just a few days. Please ... if anyone could help me on that.

share|improve this question
2  
I get "In: Hepp, Andreas und Rainer Winter, Hrsg. (2006)" –  egreg Jan 19 '13 at 9:42
    
hm ... for some reason mine looks like this: Ien, Ang (2006). Radikaler Kontextualismus und Ethnografie in der Rezeptionsforschung. In: – Hrsg. (2006). Kultur – Medien – Macht. Wiesbaden: VS Verlag für Sozial- wissenschaften., 61–79. –  Carry White Jan 19 '13 at 10:19
1  
I get the same as egreg. Which version of biblatex are you using? –  Guido Jan 19 '13 at 10:22
    
My .bbl file sais: % $ biblatex auxiliary file $ % $ biblatex version 2.0 $ % $ biber version 1.0 $ –  Carry White Jan 19 '13 at 11:12
    
@CarryWhite What TeX distribution are you using? Please upgrade biblatex and biber to their last versions. –  egreg Jan 19 '13 at 11:15

1 Answer 1

up vote 3 down vote accepted

You can use the package option dashed=false to get rid of all dashes. If you want to suppress only the dashes for the editors then try in your driver definition

 \undef\bbx@lasthash
 \usebibmacro{editor+others}

(Don't forget to put \makeatletter before the \DeclareBibliographyDriver).

Btw: You are not using the correct endash in your second entry.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.