Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've recently made the switch to biblatex from natbib but one problem I've been unable to resolve is how to make TextMate (which is my preferred editor) call biber instead of bibtex. I've installed the updated latex.tmbundle from Github, but whenever I typeset, I get unresolved references, and only the reference codes show up in the typeset document, which looks fine otherwise.

I know that biber is working, for two reasons:

  1. When I typeset in TeXShop, my document comes out looking exactly as it should, with fully parsed references;
  2. When I run the biber <file> command in terminal on the .bcf file that TextMate initially generates and then TypeSet in TextMate afterward, everything works as it should.

Any help getting TextMate to call biber automatically would be much appreciated!

share|improve this question
1  
I'm also working with TextMate and in my LaTeX preferences (those of the LaTeX-Bundle) i enabled latexmk.pl, which is for example explained here blog.mixable.de/textmate-und-latex (but only in german). With TeX Live 2011 and 2012 latexmk.pl should be able to determine itself whether to run biblatex or biber, which is stated here tex.stackexchange.com/questions/27450/… . Though, if you could provide an MWE, that would be great, because i'm not used to biber. –  Ronny Jan 22 '13 at 6:16
1  
@Ronny, Your solution worked. I also ended up replacing the latexmk.pl file with a symbolic link to TeX Live 2012's version, as described here: link. The only problem I'm still facing is that the TypeSet & View command in TextMate does not produce a TypeSet & View window or call Skim. All of the parsing is correct, however. –  Gene G. Jan 22 '13 at 19:55
    
hm, well that works fine for me, enabling the Skim preferences in the same dialog as mentioned before and leaving the Typeset&View command the same as the original (which is for me a quite longish ruby script). So what does your command produce? –  Ronny Jan 22 '13 at 22:35
    
I fixed this problem by upgrading to TM2. –  Gene G. Jan 23 '13 at 0:45
    
Nice, haven't tried TM2 yet, still running 1.5.11 –  Ronny Jan 23 '13 at 6:40
show 3 more comments

1 Answer

up vote 2 down vote accepted

There are several steps to making sure that TextMate works well with biber.

  1. Make sure you have the latest version of MacTeX installed.
  2. Install the TextMate 2.0 alpha. Here.
  3. Make sure you have the LaTeX bundle enabled. In TextMate: Preferences > Bundles > Select LaTeX bundle.
  4. Configure the LaTeX bundle to use Latexmk.pl, which automatically determines which backend to use for typesetting bibliographies. In TextMate: Bundles > LaTeX > Preferences. Set options as --shell-escape and unable "Use Latexmk.pl"
  5. If at any point biber fails to parse your references, you need to clear the cache. The issue & solution is described here. (For mac users, it is as simple as opening terminal and entering this command:

    rm -rf `biber --cache`
    
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.