Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using LaTeX template for a thesis in English. Now I need to write my thesis in Russian using the same template. I added:

\documentclass[11pt, a4paper, oneside]{Thesis}

\usepackage{cmap}               
\usepackage[utf8]{inputenc}         
\usepackage[russian]{babel} 
\usepackage{mathptmx}
\renewcommand{\sfdefault}{ptm}
\usepackage[T1]{fontenc}

Everythig works perfectly apart from units. For example I want to write units in Russian 25 ${м^3 с^{-1}}$ but I have 25 3-1. What else I need to add or remove in the index I added? Or where is my mistake?

share|improve this question
2  
By default there's no non-latin symbols in math mode. Use 25$\,\text{м}^3\text{с}^{-1}$ or 25\,м$^3$с$^{-1}$. –  Eddy_Em Jan 23 '13 at 7:00
1  
@Eddy_Em I'm pretty sure that comment should really be an answer. –  Michael Kjörling Jan 23 '13 at 9:13
    
@Eddy_Em Thank you! Both lines work perfectly. Didn't know about this way of coding. –  Sasha Jan 23 '13 at 11:43
    
@Michael Kjörling, its length too small for real answer. –  Eddy_Em Jan 23 '13 at 16:53

1 Answer 1

up vote 2 down vote accepted

Default behaviour of math mode in latex don't allow to use non-ASCII symbols.

To use russian letters in math mode you can include them into macro \text{}:

25$\,\text{м}^3\text{с}^{-1}$

or put them outside:

25\,м$^3$с$^{-1}$

Another variant is to use package mathtext:

\usepackage[warn]{mathtext}

Option warn will show warnings on every cyrillic letter in formulae (that's useful for avoiding misprints).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.