Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am going to insert an image between two subsections. When the image is big, it shifts to next page and remain an empty line between subsections. how can i remove this empty line?

and, also i put an image in a two columns format as follows:

\begin{center}

  \begin{figure*}[ht]

    \centering

    \includegraphics[width=\textwidth]{Images/Algorithm}

    \caption{Caption}

    \label{fig:label}

  \end{figure*}

\end{center}

My picture is big (in size of A4) and it goes to last page of my paper. I copied this part of code in any space of my paper, but it shift again to last of page of my paper.!!

What can I do to hold it in my favorite page?

share|improve this question

migrated from stackoverflow.com Jan 24 '13 at 20:10

This question came from our site for professional and enthusiast programmers.

    
Welcome to TeX.sx! Your post was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Werner Jan 24 '13 at 20:13
    
You might be interested in the following two posts (if they don't answer your question already; possible duplicates): How to influence the position of float environments like figure and table in LaTeX?; Keeping tables/figures close to where they are mentioned –  Werner Jan 24 '13 at 20:21

1 Answer 1

since a figure is a floating environment, placing it between \begin{center} ... \end{center} might have an effect you don't want, possibly including the unwanted blank line. (i haven't checked, since there isn't a minimum example to experiment with.)

also, if your document isn't in two columns, the * isn't helpful, since its purpose is to place a full-width float at the top of a two-column page. and if it is a two-column document, the [h] option on the figure isn't relevant.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.