Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am new to LaTeX, trying to create a table using a tabularx in a two column format. I am creating the table in a minipage so that footnotes can appear at the bottom. Everything works out fine, but the footnotes under the table are right aligned, I prefer them left aligned with the table. I browsed through several posts and forums, but couldn't figure out. Any suggestions would help.

Regards, Radhika

\documentclass[conference]{IEEEtran} 
\usepackage{tabularx,booktabs}
\listfiles
\begin{document}

\makeatletter
 \renewcommand\@makefntext[1]{%
 \parindent 1em
 \noindent
%\hb@xt@1.8em{\hss\@makefnmark}#1}
 \hbox{\hss\@makefnmark}#1}
\makeatother

\newcommand{\HRule}{\rule{\linewidth}{0.5mm}}
\newcolumntype{C}{>{\centering\arraybackslash}X} 
\newcolumntype{L}{>{\raggedright\arraybackslash}X}

\begin{table}

X\dotfill X

\begin{minipage}{1\linewidth}
X\dotfill X
\centering
\caption{Questionnaire summary}
\begin{tabularx}{1\linewidth} {l c C C L} 
\toprule
 \textbf{PID}\footnote{Participant ID}&\textbf{Challenge}\footnote{on a five-point Likert Scale 1-Not at all challenging and 5-Very challenging} &\textbf{Difference}\footnote{difference perceived by the participant as the movement progressed from \textit{source} to \textit{target}} &\textbf{Usefulness of embedded object}\footnote{on a five-point Likert Scale 1-Not at all useful and 5-Very useful} &\textbf{Point toughest to reach}\footnote{brackets indicate the Segment number corresponding to the point} \\
\midrule
 PID1&2&Yes&3&6 (Seg 5)\\
 PID2&4&No&5&2 (Seg 1)\\
 PID3&3&Yes&4&4 (Seg 3)\\
 PID4&3&No&4&2 (Seg 1)\\
\bottomrule
\end{tabularx}
\label{questionnaire}
\end{minipage}
\end{table}
\end{document}


*File List*
IEEEtran.cls 2012/11/21 V1.8c by Harald Hanche-Olsen and Anders Christensen
ot1ptm.fd 2001/06/04 font definitions for OT1/ptm.
tabularx.sty 1999/01/07 v2.07 `tabularx' package (DPC)
array.sty 2008/09/09 v2.4c Tabular extension package (FMi)
booktabs.sty 2005/04/14 v1.61803 publication quality tables

Not sure where things are going wrong?

Table image generated

share|improve this question
2  
Welcome to TeX.sx! Please complement your code to a minimal working example (MWE) illustrating your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. If I compile your current code with tabularx and booktabs, the footnotes are flushleft. –  doncherry Jan 25 '13 at 7:15
    
It turns out that IEEEtran.cls 2012/11/21 V1.8c by Harald Hanche-Olsen and Anders Christensen Is a modified IEEEtran class distributed (unfortunately) by some conference template. Deleting so that latex uses the standard IEEEtran produces a more normal layout. –  David Carlisle Jan 26 '13 at 22:29

1 Answer 1

The footnote setting is controlled by the class in use (which you didn't show) Please always post complete documents. In article and IEEEtran class footnotes are set flush left but indented by 1.8em, you can remove the indent as below.

enter image description here

\documentclass[conference]{IEEEtran} 
\usepackage{tabularx,booktabs}
\newcommand{\HRule}{\rule{\linewidth}{0.5mm}}
\newcolumntype{C}{>{\centering\arraybackslash}X} 
\newcolumntype{L}{>{\raggedright\arraybackslash}X}

\makeatletter
\renewcommand\@makefntext[1]{%
    \parindent 1em%
    \noindent
%    \hb@xt@1.8em{\hss\@makefnmark}#1}
    \hbox{\hss\@makefnmark}#1}
\makeatother

\begin{document}
\begin{table}

X\dotfill X

 \begin{minipage}{1\linewidth}
X\dotfill X

  \centering
   \caption{Questionnaire summary}
   \begin{tabularx}{1\linewidth} {l c C C L} 
   \toprule
   \textbf{PID}\footnote{Participant ID}&\textbf{Challenge}\footnote{on a five-point Likert Scale 1-Not at all challenging and 5-Very challenging} &\textbf{Difference}\footnote{difference perceived by the participant as the movement progressed from \textit{source} to \textit{target}} &\textbf{Usefulness of embedded object}\footnote{on a five-point Likert Scale 1-Not at all useful and 5-Very useful} &\textbf{Point toughest to reach}\footnote{brackets indicate the Segment number corresponding to the point} \\
   \midrule
    PID1&2&Yes&3&6 (Seg 5)\\
    PID2&4&No&5&2 (Seg 1)\\
    PID3&3&Yes&4&4 (Seg 3)\\
    PID4&3&No&4&2 (Seg 1)\\
   \bottomrule
  \end{tabularx}
  \label{questionnaire}
 \end{minipage}
\end{table}

\end{document}

The above image was generated with IEEETran 1.6 (2007) the footnote code in 1.8 (2012) is slightly different but the above definition is still appropriate if you want the footnote numbers flush left, and the image is essentially unchanged. \listfiles output: (Note that this is a slightly newer version than you reported 2012/12/27 instead of 2012/11/21 , perhaps something got fixed...

 *File List*
IEEEtran.cls    2012/12/27 V1.8 by Michael Shell
  ot1ptm.fd    2001/06/04 font definitions for OT1/ptm.
tabularx.sty    1999/01/07 v2.07 `tabularx' package (DPC)
   array.sty    2008/09/09 v2.4c Tabular extension package (FMi)
booktabs.sty    2005/04/14 v1.61803 publication quality tables
share|improve this answer
    
\documentclass[conference]{IEEEtran} –  user24021 Jan 25 '13 at 10:19
    
I am using \documentclass[conference]{IEEEtran}, your solution doesn't seem to work in my document. –  user24021 Jan 25 '13 at 10:20
    
Well that's why we always ask people to post complete documents in their questions. I have that class, I'll have a look what it does –  David Carlisle Jan 25 '13 at 10:25
    
It works for me in IEEEtran, see updated image –  David Carlisle Jan 25 '13 at 10:32
    
I copied and pasted the updated code into a fresh document (just the piece of code I can see in your answer), it wouldn't work. It is a two column format. And apart from the alignment of the footnotes, another difference I see in my table and your image is 'TABLE 1 QUESTIONNAIRE SUMMARY' appear in the same line, not in two lines as shown in your image. –  user24021 Jan 25 '13 at 11:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.