Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to make nice big quotes work in my presentation, but there is some error, a clashing of packages I assume, and I don't know how to resolve this :\

So my mwe is here:

%&latex
\RequirePackage[demo]{graphicx}
\documentclass[xcolor=dvipsnames,hyperref={breaklinks=true},mathserif,10pt]{beamer} 
\usecolortheme[named=RoyalPurple]{structure} 
\useoutertheme{infolines}
\usetheme[height=7mm]{Rochester}
\setbeamertemplate{items}[ball]
\setbeamertemplate{navigation symbols}{}
\usefonttheme{professionalfonts}

\usepackage{amsmath,amssymb,amsthm,amssymb}
\usepackage{mathtools}
\usepackage{bbm}
\usepackage{graphicx}
\usepackage{float}
\usepackage[croatian]{babel}
\usepackage{ucs}
\usepackage[utf8x]{inputenc}
\usepackage{txfonts}
\usepackage{subfigure}
\usepackage{listings}
\usepackage{time}
\usepackage{extarrows}

\usepackage{lmodern}
\usepackage{graphicx}
\usepackage{framed}

\newcommand*\openquote{\makebox(25,-22){\scalebox{5}{``}}}
\newcommand*\closequote{\makebox(25,-22){\scalebox{5}{''}}}

\makeatletter
\newif\if@right
\def\shadequote{\@righttrue\shadequote@i}
\def\shadequote@i{\begin{snugshade}\begin{quote}\openquote}
\def\endshadequote{%
  \if@right\hfill\fi\closequote\end{quote}\end{snugshade}}
\@namedef{shadequote*}{\@rightfalse\shadequote@i}
\@namedef{endshadequote*}{\endshadequote}
\makeatother

%\logo{\includegraphics[width=0.25\textwidth]{logo.eps}}

\title{RANDOM TITLE}
\subtitle{Random subtitle}
\author{John Doe}
\institute[Random institute at random place}
\date{\today}

\begin{document}
\maketitle

\begin{frame}
\frametitle{TOC}
\tableofcontents
\end{frame}

\section{Intro}

\begin{frame}
\frametitle{Intro}
\begin{columns}
    \begin{column}{0.5\textwidth}
        \begin{itemize}
        \item[]
        \flushleft{\includegraphics[width=0.5\textwidth]{elvish.eps}}
        \end{itemize}
    \end{column}
    \begin{column}{0.5\textwidth}
        \begin{shadequote}
        A common mistake that people make when trying to design something completely
        foolproof is to underestimate the ingenuity of complete fools.\par\emph{Douglas Adams}
        \end{shadequote}
    \end{column}
\end{columns}
\end{frame}

\end{document}

Basically I'd like to have image on the left and next to it (on the right) two quotes. I followed the instructions here, but I guess I made sth wrong :\ I didn't want any shade underneath my quotes so I left out the colorlet part...

So any help would be helpful.

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Summary

  • You must not leave the \colorlet part out as that is important in the definition of \shadequote, I think, based on the error I get:

Package xcolor error: Undefined error 'shadecolor'\end{frame}
  • The svgnames was important for the color name Azure so you may use the option xcolor={svgnames, dvipsnames}. Or if you don't want to load svgnames, use more generic colors or combination of them in your \colorlet{shadecolor}. If you don't want shading in your quote, use \colorlet{shadecolor}{white} instead. In that case, svgnames may not be loaded.

  • the mathserif option is already deprecated. Use \usefonttheme[onlymath]{serif} instead.

  • There is a scoping problem in \institute[Random institute at random place}. I changed [ to }.
  • Compile with the latex->dvips->ps2pdf sequence.

Revised Code

%&latex
\RequirePackage[demo]{graphicx}
\documentclass[xcolor={dvipsnames}
,hyperref={breaklinks=true}
%,mathserif
,10pt]{beamer} 
\colorlet{shadecolor}{blue}
\usefonttheme[onlymath]{serif}
\usecolortheme[named=RoyalPurple]{structure} 
\useoutertheme{infolines}
\usetheme[height=7mm]{Rochester}
\setbeamertemplate{items}[ball]
\setbeamertemplate{navigation symbols}{}
\usefonttheme{professionalfonts}

\usepackage{amsmath,amssymb,amsthm,amssymb}
\usepackage{mathtools}
\usepackage{bbm}
\usepackage{graphicx}
\usepackage{float}
\usepackage[croatian]{babel}
\usepackage{ucs}
\usepackage[utf8x]{inputenc}
\usepackage{txfonts}
\usepackage{subfigure}
\usepackage{listings}
\usepackage{time}
\usepackage{extarrows}

\usepackage{lmodern}
\usepackage{graphicx}
\usepackage{framed}

\newcommand*\openquote{\makebox(25,-22){\scalebox{5}{``}}}
\newcommand*\closequote{\makebox(25,-22){\scalebox{5}{''}}}

\makeatletter
\newif\if@right
\def\shadequote{\@righttrue\shadequote@i}
\def\shadequote@i{\begin{snugshade}\begin{quote}\openquote}
\def\endshadequote{%
  \if@right\hfill\fi\closequote\end{quote}\end{snugshade}}
\@namedef{shadequote*}{\@rightfalse\shadequote@i}
\@namedef{endshadequote*}{\endshadequote}
\makeatother

%\logo{\includegraphics[width=0.25\textwidth]{logo.eps}}

\title{RANDOM TITLE}
\subtitle{Random subtitle}
\author{John Doe}
\institute{Random institute at random place}
\date{\today}

\begin{document}
\maketitle

\begin{frame}
\frametitle{TOC}
\tableofcontents
\end{frame}

\section{Intro}

\begin{frame}
\frametitle{Intro}
\begin{columns}
    \begin{column}{0.5\textwidth}
        \begin{itemize}
        \item[]
        \flushleft{\includegraphics[width=0.5\textwidth]{elvish.eps}}
        \end{itemize}
    \end{column}
    \begin{column}{0.5\textwidth}
        \begin{shadequote}
        A common mistake that people make when trying to design something completely
        foolproof is to underestimate the ingenuity of complete fools.\par\emph{Douglas Adams}
        \end{shadequote}
    \end{column}
\end{columns}
\end{frame}

\end{document}

Output

enter image description here enter image description here enter image description here

share|improve this answer
    
Thanks, this does the trick! Is there any way I make the shading transparent? Because I have a logo in the lower right corner, and when using \colorlet{shadecolor}{white} it covers my logo :| Also, how can I change the quotes symbols? The lmodern ones are quite ugly XD –  dingo_d Jan 26 '13 at 12:56
    
AFAIK transparency does not work well with postscript. Andrew Stacey's answer in your linked post will yield easier to a transparent quote node. You can manually place the location of the quote higher perhaps. –  hpesoj626 Jan 26 '13 at 13:52
    
I have 'solved' the problem by putting another quote right under it and thus blocking the logo all together XD But thanks :D –  dingo_d Jan 26 '13 at 14:13
    
I cannot seem to get any other font to work :\ All fonts I use end up being ugly... Any info on that? –  dingo_d Jan 26 '13 at 14:43
    
If it is about the quotation marks then it is because you are using sans serif. Try serif for the quotation marks and you will see the difference. –  hpesoj626 Jan 26 '13 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.