Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
Manual font installation

I'm using MiKTeX 2.9 with TeXworks 0.4.3 and have to use a specific font(Frutiger) provided by my university.

The entire Latex template is available for download here: https://files.ifi.uzh.ch/ddis/oldweb/ddis/fileadmin/theses/general/DDIS-diploma-thesis-template-en.zip

The standalone font file is available here: https://files.ifi.uzh.ch/ddis/oldweb/ddis/fileadmin/teaching/BaKoMa/frutiger.tar.gz

According to the readme file, I have to install it like this:

 Windows Installation Notes
==========================

Usual location of texmf folder:

C:\texmf

1/ Copy the file frutiger.tar.gz into the parent directory of your texmf
folder (probably C:\).

2/ Unzip the file.

3/ Edit the file c:\texmf\miktex\config\updmap.cfg. (In case it
does not yet exist, create it as a new file.)  Add the line

Map frutiger.map

and save the file; then execute the following commands 
in a command line window ("DOS shell"):

initexmf -u
updmap

I tried it without any success and googled for hours - looks like I'm lost...

I would appreciate it a lot if someone could tell me what I'm doing wrong.

share|improve this question

marked as duplicate by Speravir, Kurt, Thorsten, Werner, lockstep Jan 26 '13 at 18:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Though here are two answers right now I want to point you to Manual font installation. –  Speravir Jan 26 '13 at 17:45

2 Answers 2

up vote 5 down vote accepted

create a local texmf tree

If no local texmf tree exists, you can create the folder C:/localtexmf. The subtrees you need depend on what you want to install into this directory, but in your case it should be sufficient to include the following:

C:/localtexmf/doc/latex
             /tex/latex

Then go to MikTeX's Settings (Admin) in the Start Menu, click on the Roots tab and add C:/localtexmf. Next click on the General tab and click on Refresh FNDB.

Complete instructions for the creation of a local texmf tree in MiKTeX can be found here. More information on TDS compliance can be found here.

install fonts

Unzip frutiger.tar.gz and copy its contents into the correct locations, e.g., the file

frutiger/texmf/dvips/base/frutiger.map

would go in C:/localtexmf/dvips/base, the folder

frutiger/texmf/fonts/tfm/adobe/frutiger

would go in C:/localtexmf/fonts/tfm/adobe/frutiger, etc.

Next, on the Windows command prompt, type

initexmf --admin --edit-config-file updmap

then add the line

Map frutiger.map

and save. Afterwards, run

 initexmf -u
 initexmf --mkmaps

Finally, refresh the FNDB. Try running kpsewhich frutiger.map on the Windows command prompt. It should return the location of the map file; if it doesn't, somehow it is not visible to TeX.

\documentclass{article}

\usepackage[T1]{fontenc}
\renewcommand{\rmdefault}{ppl}
\renewcommand{\sfdefault}{pfr}

\begin{document}
abs \textsf{abc}
\end{document}

enter image description here

share|improve this answer
    
thank you very much! I appreciate your step by step guide a lot - would still sitting here and figuring out what to do without your help! –  Airlike Jan 26 '13 at 20:24

You shouldn't put files in the main miktex folder. Better do it this way:

Unpack the tar.gz in an empty folder outside your miktex. E.g. in C:\frutiger. After unpacking you should have a folder texmf inside C:\frutiger. In texmf create a folder miktex and in miktex a folder config. Then create in the config folder a file updmap.cfg with the content

Map frutiger.map

Then go to miktex settings and add in the tab "roots" C:\frutiger\texmf as a new root.

Then run on the command line

updmap 

At last test the font with this document:

\documentclass{article}
\usepackage[T1]{fontenc}
\begin{document}
\fontfamily{pfr}\selectfont test
\end{document}
share|improve this answer
    
Yes, thanks for the reminder about not installing fonts directly in the main folder. Having read your answer, I then added notes on mine on how to create a local texmf tree. –  nnunes Jan 26 '13 at 16:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.