Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just made a nice diagram in latexDraw but the problem I am having is that I cannot seem to add mathematical symbols.

I am guessing it is because of the configuration so I looked to see if I could fix it (see image).

I am running xubuntu linux if that helps.

latexdraw preferences in linux

In the preferences is asks me for the location of the binaries and I don't know where they are. Is it the .sty files they mean or something else? will this even fix it?

Update:

I followed the advice below and typed in

>which latex

It returned

 >/usr/bin/latex

So I stuck that in but I am still having problems. Also when I clicked on the folder it went to usr/bin but the only folder it could see inside was X11

Example of problem and code produced.

    % Generated with LaTeXDraw 2.0.8
% Sun Jan 27 00:59:07 GMT 2013
% \usepackage[usenames,dvipsnames]{pstricks}
% \usepackage{epsfig}
% \usepackage{pst-grad} % For gradients
% \usepackage{pst-plot} % For axes
% User packages:
%\usepackage{graphicx}
%\usepackage[utf8]{inputenc}
%\usepackage{amsmath}
%\usepackage{pgfplots}
%\usepackage{amsmath,amsfonts,amsthm}
\begin{figure}[p]
\scalebox{1} % Change this value to rescale the drawing.
{
\begin{pspicture}(0,-2.9492188)(18.655624,2.9392188)
\psframe[linewidth=0.04,dimen=outer](4.42,1.5292188)(3.52,0.24921875)
\psline[linewidth=0.04cm](7.5,0.8492187)(4.38,0.8492187)
\psline[linewidth=0.04cm](3.56,-1.3107812)(3.56,-2.470781)
\psline[linewidth=0.04cm](3.76,-1.7107812)(3.76,-2.190781)
\pscircle[linewidth=0.04,dimen=outer](7.52,-1.0707812){0.74}
\pscircle[linewidth=0.04,dimen=outer](0.74,1.1892188){0.74}
\psline[linewidth=0.04cm](7.5,0.82921875)(7.5,-0.35078126)
\psline[linewidth=0.04cm](3.76,-1.9507812)(7.54,-1.9507812)
\psline[linewidth=0.04cm](2.04,0.88921875)(2.04,-1.9307814)
\psline[linewidth=0.04cm](3.74,0.24921875)(3.74,-0.55078125)
\psline[linewidth=0.04cm](3.96,1.5292188)(3.94,1.8092188)
\psline[linewidth=0.04cm](7.52,-1.8107812)(7.52,-1.9707812)
\psline[linewidth=0.04cm](3.52,0.88921875)(2.02,0.88921875)
\psline[linewidth=0.04cm](3.56,-1.9307814)(2.04,-1.9307814)
\psline[linewidth=0.04cm](0.75785375,0.42925632)(0.74214625,-0.5908188)
\psline[linewidth=0.04cm](0.74,1.9092188)(0.74,2.6492188)
\psline[linewidth=0.04cm](3.9400015,2.6294518)(0.72,2.6692188)
\psline[linewidth=0.04cm](1.9,-0.53078127)(0.72,-0.55078125)
\usefont{T1}{ptm}{m}{n}
\rput(3.9606247,0.86921877){\small Ge }
\usefont{T1}{ppl}{m}{n}
\rput(0.720625,1.1542188){\Large V}
\usefont{T1}{ppl}{m}{n}
\rput(7.5406246,-1.0657812){\Large A}
\usefont{T1}{ptm}{m}{n}
\rput(5.2698436,-2.5907812){\small DC Voltage Supply}
\psframe[linewidth=0.04,dimen=outer](2.2,-0.8907812)(1.9,-1.6307813)
\psline[linewidth=0.04cm,arrowsize=0.05291667cm 2.0,arrowlength=1.4,arrowinset=0.4]{->}(1.52,-0.81078124)(2.62,-1.7907811)
\psline[linewidth=0.04cm](3.32,-2.0507812)(3.32,-2.2907813)
\psline[linewidth=0.04cm](3.46,-2.1707811)(3.18,-2.1707811)
\psline[linewidth=0.04cm](4.22,-2.1907814)(3.94,-2.1907814)
\psframe[linewidth=0.04,dimen=outer](12.68,1.3892188)(11.78,0.10921875)
\psline[linewidth=0.04cm](15.8,0.74921876)(12.68,0.74921876)
\psline[linewidth=0.04cm](11.8,-1.8107812)(11.8,-2.4107811)
\psline[linewidth=0.04cm](12.0,-1.5907812)(11.98,-2.7307813)
\pscircle[linewidth=0.04,dimen=outer](15.78,-1.2107812){0.74}
\pscircle[linewidth=0.04,dimen=outer](9.0,1.0492188){0.74}
\psline[linewidth=0.04cm](15.78,0.74921876)(15.78,-0.53078127)
\psline[linewidth=0.04cm](12.02,-2.0907812)(15.8,-2.0907812)
\psline[linewidth=0.04cm](10.3,0.74921876)(10.3,-2.0707812)
\psline[linewidth=0.04cm](12.22,0.08921875)(12.22,-0.7107813)
\psline[linewidth=0.04cm](15.78,-1.9507812)(15.78,-2.1107812)
\psline[linewidth=0.04cm](11.78,0.74921876)(10.28,0.74921876)
\psline[linewidth=0.04cm](11.82,-2.0707812)(10.3,-2.0707812)
\psline[linewidth=0.04cm](9.0,0.32921875)(8.98,-0.69078124)
\psline[linewidth=0.04cm](9.0,1.7492187)(9.0,2.4892187)
\psline[linewidth=0.04cm](12.28,2.4892187)(8.98,2.5092187)
\psline[linewidth=0.04cm](10.16,-0.67078125)(8.96,-0.69078124)
\usefont{T1}{ptm}{m}{n}
\rput(12.220625,0.7292187){\small Ge }
\usefont{T1}{ppl}{m}{n}
\rput(9.000625,0.9742187){\Large V}
\usefont{T1}{ppl}{m}{n}
\rput(15.800625,-1.2057812){\Large A}
\usefont{T1}{ptm}{m}{n}
\rput(13.529843,-2.7307813){\small DC Voltage Supply}
\psframe[linewidth=0.04,dimen=outer](10.46,-1.0307813)(10.16,-1.7707813)
\psline[linewidth=0.04cm,arrowsize=0.05291667cm 2.0,arrowlength=1.4,arrowinset=0.4]{->}(9.78,-0.9507812)(10.88,-1.9307811)
\psline[linewidth=0.04cm](11.58,-2.2307813)(11.58,-2.4707813)
\psline[linewidth=0.04cm](11.72,-2.3507812)(11.44,-2.3507812)
\psline[linewidth=0.04cm](12.52,-2.3707812)(12.24,-2.3707812)
\psline[linewidth=0.06cm,arrowsize=0.05291667cm 2.0,arrowlength=1.4,arrowinset=0.4]{<-}(16.54,1.1087693)(17.407234,1.6736897)
\psline[linewidth=0.06cm,arrowsize=0.05291667cm 2.0,arrowlength=1.4,arrowinset=0.4]{<-}(17.42,2.9092188)(17.421688,1.700552)
\psline[linewidth=0.06cm,arrowsize=0.05291667cm 2.0,arrowlength=1.4,arrowinset=0.4]{->}(17.421688,1.6736897)(18.6,1.6492188)
\usefont{T1}{ptm}{m}{n}
\rput(18.525469,1.4342188){x}
\usefont{T1}{ptm}{m}{n}
\rput(17.673437,2.7942188){z}
\usefont{T1}{ptm}{m}{n}
\rput(16.747812,1.0342188){y}
\psdots[dotsize=0.12](7.5,0.82921875)
\psdots[dotsize=0.12](7.54,-1.9707812)
\psdots[dotsize=0.12](15.82,-2.1107812)
\psdots[dotsize=0.12](15.8,0.70921874)
\psarc[linewidth=0.04](2.04,-0.53078127){0.18}{0.0}{180.0}
\psline[linewidth=0.04cm](3.74,-0.49078125)(2.22,-0.49078125)
\psarc[linewidth=0.04](10.3,-0.69078124){0.18}{0.0}{180.0}
\rput{87.473885}(5.7319264,-2.1319435){\psarc[linewidth=0.04](3.98,1.9292188){0.18}{0.0}{180.0}}
\psline[linewidth=0.04cm](3.96,2.6692188)(3.96,2.1292188)
\psline[linewidth=0.04cm](12.22,1.3692187)(12.2,1.6492188)
\rput{87.473885}(13.507985,-10.498628){\psarc[linewidth=0.04](12.24,1.8092188){0.18}{0.0}{180.0}}
\psline[linewidth=0.04cm](12.26,2.5092187)(12.26,1.9692187)
\psline[linewidth=0.04cm](10.5,-0.69078124)(12.22,-0.7107813)
\psline[linewidth=0.04cm](11.22,0.74921876)(11.22,1.8892188)
\psline[linewidth=0.04cm](11.2,1.8492187)(12.96,1.8492187)
\psline[linewidth=0.04cm](12.96,1.8292187)(12.96,0.7292187)
\psline[linewidth=0.04cm](4.74,1.9492188)(4.74,0.8492187)
\psline[linewidth=0.04cm](3.04,0.82921875)(3.04,1.9692187)
\psline[linewidth=0.04cm](3.0,1.9292188)(4.76,1.9292188)
\usefont{T1}{ptm}{m}{n}
\rput(5.2814064,1.3942188){\psframebox*[framesep=0, boxsep=false,fillcolor=white] {$\Omega$}}
\psdots[dotsize=0.12](3.08,0.87921876)
\psdots[dotsize=0.12](4.76,0.89921874)
\psdots[dotsize=0.12](11.24,0.75921875)
\psdots[dotsize=0.12](13.02,0.7992188)
\usefont{T1}{ptm}{m}{n}
\rput(13.541407,1.4142188){\psframebox*[framesep=0, boxsep=false,fillcolor=white] {$\Omega$}}
\end{pspicture} 
}
\end{figure}

The userpackages bit is my contribution that I put in. the picture produced. The math package is being ignored

share|improve this question
    
Try /usr/bin. Or some folder on /usr/local/texlive. –  Sigur Jan 27 '13 at 0:19
    
it will mean the executable latex itself (and bibtex) etc, if you can run latex on the command line then it's in your path somewhere which latex would tell you on my system it says which latex /usr/local/texlive/2012/bin/i386-cygwin/latex so it would want /usr/local/texlive/2012/bin/i386-cygwin but your path will be different –  David Carlisle Jan 27 '13 at 0:20
    
@DavidCarlisle thanks. Can you read my edit and let me know what you make of it please? Thanks. –  Magpie Jan 27 '13 at 0:37
    
I guess I'll pass sorry I have never used that system and don't have a linux machine here at present, you wouldn't expect many or any subfolders of /usr/bin other than X11 so that sounds normal. –  David Carlisle Jan 27 '13 at 0:44
    
yeah I think it found it. I found a place to add packages now too but it doesn't seem to make a different. I will add the picture –  Magpie Jan 27 '13 at 0:56
show 2 more comments

1 Answer 1

If you are on Linux, you do not have to set the path of the LaTeX binaries. This field mainly is for Windows users and custom configurations.

If you have compilation issues, it comes from LaTeX packages that you must include in your drawing. For that, you can either go into the preferences in the LaTeX tab to set the packages to use for all the drawings, or with latexdraw 2.0.8 go into the properties of the current drawing and set the packages to use for the current drawing. With latexdraw 3.x to set the packages to use for a drawing, you must click on the text button and a tool bar will appear at the bottom of the application. In the toolbar you can set the packages.

share|improve this answer
    
Welcome to TeX.sx! –  Kurt Mar 16 '13 at 19:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.