Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For American Society of Genetics journal (Genetics), the bibliography format is somewhat strange. It requires no parenthesis or comma after year field.

Beadle, G. B. et al. 2009 Title of the paper. Non-Italic-Name-of-Journal 88: 203-209

I am getting: Beadle, G. B. et al. 2009. Title.... And the journal name is printing in italics.

Can someone help me with getting rid of the period after the 'year' field and removing the italicized Journal font?

Edit1: I am using biblatex with authoryear style and natbib=true.

share|improve this question
2  
Welcome to TeX.SE! Could you edit your question to provide a hyperlink to the bibliography style file, or at least the name of this file? Thanks. –  Mico Jan 28 '13 at 8:17
    
@Mico One of the tags is biblatex, so more than the style we need the biblatex options (including the style) –  Guido Jan 28 '13 at 10:28
add comment

1 Answer

It might depends on the specific style used, but for standard biblatex authoryear style, one should be able to remove the punctuation after the year with

\renewcommand{\labelnamepunct}{\addspace}

and to prevent the journal title to be printed in italics, the following should do the trick

\DeclareFieldFormat{journaltitle}{#1} 
share|improve this answer
2  
Perfect Guido! Both solutions work very well. Since I am new to biblatex, its rather difficult to make the connection between identifiers such as labelnamepunct to year punctuations. But I am glad to see that Biblatex has so many options available. This is much better than editing .bst. –  cryptic0 Jan 28 '13 at 14:56
    
@cryptic0 That one is a very hard one indeed. The problem is that the spec to print the year in the authoryear style is inside the macro for translator, which is then inside that of author/editor+other. –  Guido Jan 29 '13 at 1:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.