TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Some days ago, I've updated my Miktex 2.8 installation (on Windows 7). However, since doing that I have problems with latexdiff (it did work before). When I run it, I get:

latexdiff: the Perl script could not be found
latexdiff: Data: latexdiff

So, it seems the latexdiff.exe (there is one under C:\Program Files (86)\MikTeX 2.8\miktex\bin\latexdiff.exe, and another one under C:\Users\myname\AppData\Roaming\MikTeX\2.8\miktex\bin\latexdiff.exe) doesn't find the actual Perl script. There are some Perl files under scripts\latexdiff.

Things I've done/checked:

  • I first thought it was a Perl problem, but the perl interpreter is still working and available at the command line
    If I do perl "C:\Program Files (x86)\MiKTeX 2.8\scripts\latexdiff\latexdiff -h the script works fine.

  • I've already removed and reinstalled the latexdiff package using both the MikTex Package Maintenance and Package Maintenance (Admin), but that didn't help.

  • It doesn't seem to be an admin/regular user issue, as calling either of the two latexdiff.exe files explicitly (the global one, or the user one) gives the same problem.

  • Other scripts like texdiff and pdfcrop which also use a similar perl-script-redirection setup still can be called without problems.

  • the miktex\config\scripts.ini file seems to refer to the correct path, as it has the line latexdiff=scripts/latexdiff/latexdiff.
    Although I noticed that the latexdiff lines are the one of only a few ones that do NOT end with .pl (arlatex, bundledoc, latexpand, latexrevise, makeglossaries, pkfix-helper, urlbst where to other ones without .pl extension)

  • I've checked the miktex\config\update-<date>.log files and in the most recent one there is no entry of latexdiff in the "Making Per links..." part, wheres in older log files, there was.

I don't want to re-install MikTex to fix this problem.

As a workaround for now, I have sort-of created a wrapper script that calls perl "C:\Program Files (x86)\MiKTeX 2.8\scripts\latexdiff\latexdiff, instead of just latexdiff.exe, with whatever options I append.

Some more background: The reason I updated MikTeX some days ago was because I was having a compile problem when using pdftex. I got the error I can't find file 'dehypht-x-2009-06-19.tex'. I tried solving this by updating MikTeX. Didn't help. Was able to resolve it by opening the MikTex Settings program (Windows Start Menu > MikTex > Maintenance > Settings), and deselecting the relevant German language under the Language tab. Don't know if this is relevant or not.

share|improve this question

closed as too localized by Speravir, Claudio Fiandrino, Stefan Kottwitz Jan 30 '13 at 17:06

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

DId it work before? As far as I know MikTeX does not ship with a build in Perl interperter, only TeX Live does that on windows. So for the Perl based tool in MikTeX you will hjave to install a Perl interpreter manually. – daleif Jan 28 '13 at 14:48
@daleif: Yes it worked before. And I have strawberry perl installed and still working. – Rabarberski Jan 28 '13 at 14:51
I just tried and had no problems, but 1. I have miktex 2.9 and 2. I have a single user installation. You could check in miktex\config\scripts.ini if the pathes to the perl files are correct. (Check all scripts.ini, it is possible that you have more than one. And don't mess around with this files, they are signed, if you change them, miktex will refuse to use the files.). – Ulrike Fischer Jan 28 '13 at 15:23
I have the same problem with my texdef Perl script with MikTeX 2.9. I already contacted the MikTeX maintainer Christian Schenk about it and he responded that he will have a look at it shortly. Seeing your question here now, it looks like it is a more general problem with Perl scripts. Therefore I contacted him again now with a link to this question. – Martin Scharrer Jan 28 '13 at 21:03
@Ulrike: I know; I took a copy before editing and put the copy back afterwards. BTW: I appreciate the persistence you have shown in trying to sort this out. – Rabarberski Jan 30 '13 at 13:07

protected by Martin Scharrer Jan 29 '13 at 21:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.