TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been using MikTex on Windows XP and 7 for few months now and I faced no issues in installing packages that needs to be done on the fly.

However, with Windows 8, the packages are not updated at all.

Does anyone know how to overcome this issue?

As an example, I tried to build the following "http://courses.engr.illinois.edu/cs573/fa2011/Homework/hw5.tex" which requires the "fullpage" package. However, I always get build error saying,

! LaTeX Error: File `fullpage.sty' not found.Type X to quit or to proceed,or enter new name. (Default extension: sty)Enter file name:! Emergency stop. \usepackage

Does anyone know how to overcome this issue?

share|improve this question
Open the MikTeX options (adm) and set it to install from the internet. Choose a repository. – Sigur Jan 29 '13 at 1:16
@Sigur: I actually did that, but not result. I even tried swapping among different repository. – Shamim Hafiz Jan 29 '13 at 1:24
After choose a repository use the package manager to find and install new packages and then run the refresh database. – Sigur Jan 29 '13 at 1:28
It seems to me, it is once again a permission problem, cf. the memory dump file could not be found. – Speravir Jan 29 '13 at 2:26
So yo can/must confirm what is written in the other answer? – Speravir Jan 29 '13 at 2:54
up vote 2 down vote accepted

I was trying to have the packages updated while running TexMaker. This process always failed if I did not start TexMaker as an Administrator.

The issue is resolved if Texmaker is run as Administrator. I guess this is something both Texmaker and MikTex should look into resolving.

share|improve this answer
I guess, yo have MiKTeX installed under C:\Program Files or an equivalent? You could try to reinstall outside of it. Relocate MiKTeX 2.9? should help you. – Speravir Feb 1 '13 at 19:48

Try to choose a repository from the United States. I was using a random repository from Brazil and I had security issues.

share|improve this answer

@Shamim Hafiz might be right, because what solve my problem was to install the MiKTeX 2.9 in the compatibility mode pointing out that MiKTeX used to work well in Win7. I completed the installation and then, I also executed the Texwork editor (the default editor installed with MiKTeX) in the compatibility mode.

After checking that my file was compiling ok in that editor, I saved the configuration in the Windows assistant by saying that my problem was solved by executing as if it were Win7. Finally, I executed my editor (Texmaker) and everything went well.

My opinion is that Win8 is the problem although I had been working with Win8+MiKTeX 2.7+Texmaker for quite a long time, but suddenly it crashed. But now it's working again.

share|improve this answer
Welcome to TeX.SX! – Heiko Oberdiek Jun 25 '15 at 2:44
Thank you! Glad to help – Daniel Santiago Jun 26 '15 at 4:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.