Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How do I suppress the leading space on a citation so that I get ([1],[2]) instead of ( [1],[2]) on a single instance of cite? The only answer I've seen so far is to

\usepackage[nospace,noadjust]{cite}

but that sets the option for all citations. I tried

\cite[noadjust]{mycitationkey}

and it didn't work.

share|improve this question
2  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. It will be much easier for us to reproduce your situation and find out what the issue is when we see compilable code, starting with \documentclass{...} and ending with \end{document}. –  egreg Jan 30 '13 at 22:44
add comment

1 Answer

The option noadjust is defined as

 \DeclareOption{noadjust}{\let\cite@adjust\@empty}% Don't change spaces

So try making this assignemnt in a group (untested since you do not have MWE):

\makeatletter
\newcommand\noadjustcite[1]{\bgroup
   \let\cite@adjust\@empty
   \cite{#1}%
\egroup}
\makeatother

...

\cite{one}, \noadjustcite{two,three}...
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.