Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When I use xelatex.exe --output-directory=./tmp TeXwork PDF preview will not work. Is there any solution?

share|improve this question
    

1 Answer 1

The short answer here is 'no', as TeXworks expects to find the PDF file in the same directory as the .tex file when doing a typesetting run. The only obvious work-around would be to create a short script as a wrapper around XeLaTeX, which would copy the PDF from the output directory to the 'current' one after the xelatex run, leaving all of the other files out of the way. You'd then use the script in place of the xelatex binary when setting up the typesetting entry.

share|improve this answer
    
Thanks, I hope we see a config for pdf path in future TeXworks releases. –  PHPst Aug 6 '13 at 7:41
    
@PHPst Well yes, would answer this answer some other questions: have you made a feature request? –  Joseph Wright Aug 6 '13 at 7:42
    
No, Where can I make a NFR? –  PHPst Aug 6 '13 at 9:22
    
    
@Thanks again. I wonder that they live in Google Code yet! –  PHPst Aug 6 '13 at 9:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.