Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I just switched from TexMaker to TexStudio - one of the main reasons is the improved spellchecker that lets you add words your ignore list directly (instead of manually modifying the .dic file, as you had to do with TexMaker).

All in all I am quite happy, but something is still bugging me. TexStudio spellchecker does not ignore special characters. So if I write...

The boy walked past the `house'.
                         ^^^^^^^

TexStudio will actually check for house'. and will not recognize it. Meaning I'll have to add every such combination to the ignore list manually.

Is there any way to not spellcheck special character-containing words?

And possibly ignore all LaTeX variables and command parameters too? Getting tired of the spellchecker also checking htp!, which is the placement parameter on image import commands... :/


P.S.
I am aware that some people prefer to write

The boy walked past the `house.'

but that is not really the discussion I'd like to get into here...

share|improve this question
    
If en_US or en_GB is loaded I don't get the behavior you described. I get the behavior though if I switch to other dictionaries. –  hpesoj626 Feb 1 '13 at 10:36
    
I am using en_GB... –  fgysin Feb 1 '13 at 13:32
add comment

1 Answer

up vote 2 down vote accepted

The quotation issue is a bug in the tokenizer. Will be fixed in the next release.

There are currently no options to configure the spellchecking options, like excluding options. You may add an entry to the feature request tracker: http://sourceforge.net/p/texstudio/feature-requests/

share|improve this answer
    
I feared as much... Am I wrong or has this been an open issue for quite a while? I faintly remember writing a project report around 1-2 years ago and encountering the very same problem back then... –  fgysin Feb 4 '13 at 8:40
    
I opened a ticket on sourceforge, lets hope it gets fixed... –  fgysin Feb 4 '13 at 9:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.