Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I was trying to type math in captions with a sans font when I came upon the mathastext package and I got greedier. I tested it with the following MWE:

\documentclass{memoir}

\usepackage[mdugm]{mathdesign}
\usepackage[subdued,defaultnormal,defaultrm,italic]{mathastext}
\usepackage{garamondx}
\usepackage{biolinum-type1}
\renewcommand\familydefault\sfdefault
\Mathastext[biolinum]
\useosf% changes figure style in garamondx
\renewcommand\familydefault\rmdefault

\newcommand{\testtext}{%
Distribution of singularities -- zeroes and poles -- for
the transfer function $A_v(f)$ in the $s$-domain according to $Q$.
\emph{Remark:} Observe that for $Q=1/2$, we have $p_0=\omega_0$. 
Testing oldstyle figures 0123456789.
\begin{equation}
 V_i(j\omega)=\frac{1}{2}
 \sum_n{}V_n\exp\{-j\phi_n\}\delta(j\omega\pm{}j\omega_n)\,,
\end{equation}}

\begin{document}
\pagestyle{empty}
%\MTVersion{normal}
\testtext
\par\MTVersion{biolinum}
\testtext
\end{document}

Almost everything works fine, but there are a couple of things I'd like to get fixed.

First, there are glyph collisions in math mode both in the roman font and in the sans font -- check the (f and the (j. The former does not occur when I do not resort to the mathastext package. Hence, I'd like to be able to use the package but either avoiding such collision or loading it only to have available a "sans math" mode. I haven't been able to load the packages in order for the math roman to be not affected by the mathastext package, though -- which, as I advanced, is interesting since the collisions do not occur when loading the mathdesignpackage without appending mathastext. Any help or suggestion about this issue?

Secondly, I'd like to avoid the glyph collision in the sans font. Is there a convenient way to avoid it without having to issue a command or a control sequence every time I'm going to type (f or (j?

Lastly, when using the sans font I get oldstyle figures even for math mode. Maybe this has to do with the biolinum-type1 package, but how could I have text figures in text mode and lining figures in math mode?

share|improve this question

1 Answer 1

I can not test currently you MWE due to some font package problems, but recently mathastext has been updated with a new function \MTsetmathskips. So you could try to add in the preamble:

\makeatletter
\@tfor\@tempa:=abcdefghijklmnopqrstuvwxyz\do
    {\MTsetmathskips\@tempa{.5mu}{.5mu}}
\MTsetmathskips{j}{1.5mu}{.5mu}
\MTsetmathskips{f}{1.5mu}{.5mu}
\makeatother

This will space out the letters in (non-subdued) math mode. To be used sparingly... (currently also operator names like exp are spread out, I guess some option should be provided to not do that).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.