Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've installed latest releases of MiKTeX, GhostScript and Texmaker, but I can't compile anything. The error message "Could not run the command" appears. How do I configure it?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Go to Options -> Configure Texmaker and change the paths for the programs. You can choose the correct one using the button on the right of the text field, and then copy the path with Ctrl+C and then Ctrl+V for the other programs.

share|improve this answer
    
Should all the features be installed? –  lexeme Jan 25 '11 at 9:41
    
It is only a copy and paste ... If you did it not this time than you'll forget about it ... So it is save to do it for all. –  Herbert Jan 25 '11 at 9:53
add comment

If you used the MiKTeX net installer (5.51 MB for version 2.9), make sure that the packages were installed and not just downloaded. This installer downloads packages just like the Cygwin installer. However, it does not install them automatically. You need to launch the installer again and tell it to install the downloaded packages. I recently installed MiKTeX on Win7 and had to go through this process. I recommend to :

  • Check if MiKTeX is installed. The default installation directory is C:\Program Files (x86)\MiKTeX 2.9.
  • Check if latex is visible from your path by typing latex --version on the command line.

MiKTeX installer screenshot

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.