TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After each abbreviation there is a paragraph in my glossary except in one row. (see screenshot). There is no separation between the "W3C" and "WHATWG" abbreviation.

enter image description here

Does anyone know what I can do?

This is my code:

% Glossary package


% Abbreviations
\newacronym{html}{HTML}{Hypertext Markup Language}
\newacronym{cern}{CERN}{Conseil Européen pour la Recherche Nucléaire}
\newacronym{w3c}{W3C}{World Wide Web Consortium}
\newacronym{sgml}{SGML}{Standard Generalized Markup Language}
\newacronym{xml}{XML}{Extensible Markup Language}
\newacronym{ie9}{IE9}{Internet Explorer 9}
\newacronym{xhtml}{XHTML}{Extensible HyperText Markup Language}
\newacronym[longplural=Rich Internet Applications]{ria}{RIA}{Rich Internet Application}
\newacronym{ajax}{AJAX}{Asynchronous JavaScript and XML}
\newacronym{whatwg}{WHATWG}{Web Hypertext Application Technology Working Group}
\newacronym{swf}{SWF}{Small Web Format}

% Output


share|improve this question
I see another pair with no separation: SGML and SWF. Looks like the entries are grouped by their initials. – egreg Feb 6 '13 at 0:08
as @egreg said, also and XHTML/XML – David Carlisle Feb 6 '13 at 0:22
up vote 4 down vote accepted

Your acronym list is based on longtable, and is a grouped style. The groups are separated by an empty row in the longtable. To get rid of that row, we define a new style based on long:


This shall be put in the preamble after loading glossaries. To use it, issue

share|improve this answer
Good suggestion! But unfortunately it does not help. :( I did the following: \usepackage[nopostdot,nonumberlist,acronym,toc,section]{glossaries} \renewcommand*{\glsgroupskip}{} \makeglossaries – Benny Neugebauer Feb 6 '13 at 0:52
@BennyNeugebauer My bad. I updated the answer, now it should work. This time I even tested it ;-) – mafp Feb 6 '13 at 1:43
Worked like a charm, thank you! – Benny Neugebauer Feb 6 '13 at 1:55

If you have a recent version of glossaries you can use the nogroupskip package option to suppress the gap between letter groups.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.