Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I totally purged TexLive from my system, and then I installed the latest version of TexLive from the internet installer as described here instead of via the Ubuntu package manager.

Next, I installed Winefish (the latex editor) using the package manager, and here is the install log:

me@home:~$ sudo apt-get install winefish 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  lmodern luatex tex-common texlive-base texlive-binaries texlive-common
  texlive-doc-base texlive-luatex tidy tofrodos
Suggested packages:
  perl-tk tidy-doc
The following NEW packages will be installed:
  lmodern luatex tex-common texlive-base texlive-binaries texlive-common
  texlive-doc-base texlive-luatex tidy tofrodos winefish
0 upgraded, 11 newly installed, 0 to remove and 9 not upgraded.
Need to get 46.2 MB/46.5 MB of archives.
After this operation, 101 MB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get:1 http://archive.linux.duke.edu/ubuntu/ precise/main tex-common all 2.10 [709 kB]
Get:2 http://archive.linux.duke.edu/ubuntu/ precise/main lmodern all 2.004.1-3.1ubuntu1 [17.8 MB]
Get:3 http://archive.linux.duke.edu/ubuntu/ precise/main luatex amd64 0.70.1-1ubuntu1 [2,458 kB]
Get:4 http://archive.linux.duke.edu/ubuntu/ precise/main texlive-common all 2009-15 [94.4 kB]
Get:5 http://archive.linux.duke.edu/ubuntu/ precise/main texlive-doc-base all 2009-2 [1,339 kB]
Get:6 http://archive.linux.duke.edu/ubuntu/ precise/main texlive-binaries amd64 2009-11ubuntu2 [8,054 kB]
Get:7 http://archive.linux.duke.edu/ubuntu/ precise/main texlive-base all 2009-15 [14.7 MB]
Get:8 http://archive.linux.duke.edu/ubuntu/ precise/main texlive-luatex all 2009-15 [975 kB]
Get:9 http://archive.linux.duke.edu/ubuntu/ precise/main tidy amd64 20091223cvs-1ubuntu2 [24.2 kB]
Get:10 http://archive.linux.duke.edu/ubuntu/ precise/main tofrodos amd64 1.7.9.debian.1-1 [21.0 kB]
Fetched 46.2 MB in 3min 22s (228 kB/s)                                         
Preconfiguring packages ...
Selecting previously unselected package tex-common.
(Reading database ... 295442 files and directories currently installed.)
Unpacking tex-common (from .../tex-common_2.10_all.deb) ...
Selecting previously unselected package lmodern.
Unpacking lmodern (from .../lmodern_2.004.1-3.1ubuntu1_all.deb) ...
Selecting previously unselected package luatex.
Unpacking luatex (from .../luatex_0.70.1-1ubuntu1_amd64.deb) ...
Selecting previously unselected package texlive-common.
Unpacking texlive-common (from .../texlive-common_2009-15_all.deb) ...
Selecting previously unselected package texlive-doc-base.
Unpacking texlive-doc-base (from .../texlive-doc-base_2009-2_all.deb) ...
Selecting previously unselected package texlive-binaries.
Unpacking texlive-binaries (from .../texlive-binaries_2009-11ubuntu2_amd64.deb) ...
Selecting previously unselected package texlive-base.
Unpacking texlive-base (from .../texlive-base_2009-15_all.deb) ...
Selecting previously unselected package texlive-luatex.
Unpacking texlive-luatex (from .../texlive-luatex_2009-15_all.deb) ...
Selecting previously unselected package tidy.
Unpacking tidy (from .../tidy_20091223cvs-1ubuntu2_amd64.deb) ...
Selecting previously unselected package tofrodos.
Unpacking tofrodos (from .../tofrodos_1.7.9.debian.1-1_amd64.deb) ...
Selecting previously unselected package winefish.
Unpacking winefish (from .../winefish_1.3.3-0dl1ubuntu1_amd64.deb) ...
Processing triggers for doc-base ...
Processing 3 added doc-base files...
Registering documents with scrollkeeper...
Processing triggers for man-db ...
Processing triggers for fontconfig ...
Processing triggers for install-info ...
Processing triggers for menu ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for shared-mime-info ...
Setting up tex-common (2.10) ...
Not replacing deleted config file /etc/texmf/texmf.d/05TeXMF.cnf
Not replacing deleted config file /etc/texmf/texmf.d/15Plain.cnf
Not replacing deleted config file /etc/texmf/texmf.d/45TeXinputs.cnf
Not replacing deleted config file /etc/texmf/texmf.d/55Fonts.cnf
Not replacing deleted config file /etc/texmf/texmf.d/65BibTeX.cnf
Not replacing deleted config file /etc/texmf/texmf.d/75DviPS.cnf
Not replacing deleted config file /etc/texmf/texmf.d/80DVIPDFMx.cnf
Not replacing deleted config file /etc/texmf/texmf.d/85Misc.cnf
Not replacing deleted config file /etc/texmf/texmf.d/90TeXDoc.cnf
Not replacing deleted config file /etc/texmf/texmf.d/95NonPath.cnf
Not replacing deleted config file /etc/texmf/updmap.d/00updmap.cfg
update-texmf: Basic configuration file /etc/texmf/texmf.d/05TeXMF.cnf missing.
Exiting.
dpkg: error processing tex-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of lmodern:
 lmodern depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
dpkg: error processing lmodern (--configure):
 dependency problems - leaving unconfigured
Setting up luatex (0.70.1-1ubuntu1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          texlive-base is not ready, cannot create formats
dpkg: dependency problems prevent configuration of texlive-common:
 texlive-common depends on tex-common (>= 2.0); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-doc-base:
 texlive-doc-base depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
 texlive-doc-base depends on texlive-common (>= 2009-1); however:
  Package texlive-common is not configured yet.
dpkg: error processing texlive-doc-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-binaries:
 texlive-binaries depends on texlive-common (>= 2009); however:
  Package texlive-common is not configured yet.
 texlive-binaries depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
dpkg: error processing texlive-binaries (--configure):
 dependency proNo apport report written because the error message indicates its a followup error from a previous failure.
                                         No apport report written because MaxReports is reached already
                       No apport report written because MaxReports is reached already
     No apport report written because MaxReports is reached already
                                                                   No apport report written because MaxReports is reached already
                                                 blems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-base:
 texlive-base depends on texlive-doc-base (>= 2009-1); however:
  Package texlive-doc-base is not configured yet.
 texlive-base depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
 texlive-base depends on texlive-binaries (>= 2009-10); however:
  Package texlive-binaries is not configured yet.
 texlive-base depends on texlive-common (>= 2009-1); however:
  Package texlive-common is not configured yet.
dpkg: error processing texlive-base (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of texlive-luatex:
 texlive-luatex depends on tex-common (>= 2.00); however:
  Package tex-common is not configured yet.
 texlive-luatex depends on texlive-base (>= 2009-1); however:
  Package texlive-base is not configured yet.
 texlive-luatex depends on texlive-common (>= 2009-1); however:
  Package texlive-common is not configured yet.
dpkg: error processing texlive-luatex (--configure):
 dependency problems - leaving unconfigured
Setting up tidy (20091223cvs-1ubuntu2) ...
Setting up tofrodos (1.7.9.debian.1-1) ...
dpkg: dependency problems prevent configuration of winefish:
 winefish depends on tetex-bin | texlive-base-bin | latex; however:
  Package tetex-bin is not installed.
  Package texlive-base-bin is not installed.
  Package texlive-binaries which provides texlive-base-bin is not configured yet.
  Package latex is not installed.
dpkg: error processing winefish (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 tex-common
 lmodern
 texlive-common
 texlive-doc-base
 texlive-binaries
 texlive-base
 texlive-luatex
 winefish
E: Sub-process /usr/bin/dpkg returned an error code (1)

I can successfully use the latex binary, but some things don't work. For example, when I try to run dvips, I get the following:

me@home:Note$ dvips Note.dvi 
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/share/texmf/web2c:/usr/share/texmf-texlive/web2c:/usr/local/share/texmf/web2c.
This is dvips(k) 5.98 Copyright 2009 Radical Eye Software (www.radicaleye.com)
dvips: ! Couldn't find header file tex.pro.
Note that an absolute path or a relative path with .. are denied in -R2 mode.

I don't think my installing Winefish actually caused the problem, but I'm including that information in case it did.

[Additionally info added below.]

For diagnostic purposes, I did the following (which I read about elsewhere):

me@home:~$ kpsewhich -var-value=TEXMF
warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/share/texmf/web2c:/usr/share/texmf-texlive/web2c:/usr/local/share/texmf/web2c.

Then, using locate, I discovered that /usr/share/texmf/web2c/texmf.cnf does exist, but it's a broken symbolic link to /etc/texmf/texmf.cnf.

Does this help shed light on the problem?

share|improve this question
add comment

2 Answers 2

up vote 4 down vote accepted

You installed texlive again from Ubuntu repositories while installing Winefish (excerpt from your log):

The following extra packages will be installed: lmodern luatex tex-common texlive-base texlive-binaries texlive-common
texlive-doc-base texlive-luatex tidy tofrodos

After installing "vanilla TeX Live" from TUG, you need to create some "fake" packages, to make Ubuntu think TeX Live is installed from repositories and not crapping around with dependencies as described in this question about installation on Debian or Ubuntu or on a TeXBlog-Post (quite old—as it is for TL2008—but might still work the same).

In order to repair your installation, I'd purge the automatically installed Ubuntu-packages and vanilla TeX Live and install the last one again, creating the "fake"-packages then and at last install Winefish.

Edit: The default installation location for TeX Live from TUG is /usr/local/texlive, so the files you found are definitly not those you want to have

share|improve this answer
    
See bottom of tug.org/texlive/debian.html on how you build the fake package. You may still see a few texlive- Ubuntu packages when installing winefish but they seem to be meta packages of just a few Kb –  daleif Feb 6 '13 at 11:52
1  
This answer is extremely helpful. Thank you. –  synaptik Feb 6 '13 at 19:47
add comment

After doing

sudo apt-get purge texlive* tex-common*

it works. So, apparently installing Winefish via apt was the problem.

share|improve this answer
    
Now I have also reinstalled winefish, and it works. But, winefish doesn't work. Does anyone here know what's going on? –  synaptik Feb 6 '13 at 5:03
    
sorry, I don't understand completely yet. What works and what doesn't? I believe TeXLive comes with TeXWorks which you could use an editor. –  Tim A Feb 6 '13 at 14:27
    
@TimA Although I've yet to take the actions suggestion by Stephan, which I suspect will resolve my problem, the problem currently is that the Winefish editor does not work. In order to try to get Winefish installed without apt installing texlive over my not-apt texlive install, I installed the Winefish packages manually without allowing Ubuntu to satisfy dependencies. So, I'm going to take Stephan advice, and then see where things stand. –  synaptik Feb 6 '13 at 19:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.