Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to automate my LaTeX pdf output within TeXnicCenter. I am using pdflatex with biber and it's been proposed to get the following settings:

enter image description here

However, whenever I add a new \autocite{xyz} in my document, TeXnicCenter outputs an error: Citation xyz not found.

When I rerun biber manually, with biber file.bcf and recompile with pdflatex it works.

How can I automate my process, to just compile and recompile from within TeXnicCenter?

Note: My problem is NOT being discussed or solved with this question.

share|improve this question
1  
Please add a minimal working or non working example (MWE) that illustrates your problem. I'm using Biber without any problems on TC 2 Beta –  percusse Feb 7 '13 at 17:32
    
@percuße: Which setting do you use? A MWE seems too complex for this problem as its not connected to data. –  Martin Betz Feb 7 '13 at 17:54
    
Have you ever tried latexmk? It’s a perl script (available from CTAN, included in MiKTeX) that automatically determines what needs to be run and does it. I’ve used it with Biber, and it works with a bunch of other things as well. Also, the maintainer is really responsive and answers questions here. So in your case, you’d just call latexmk -pdf foo.tex. Basically, the automation you’re trying to achieve has already been implemented with a general solution. –  doncherry Feb 7 '13 at 18:11
    
Just a small example to show that the citation doesn't work is sufficient. No need to include all the details. –  percusse Feb 7 '13 at 18:14
    
For a code piece for a bibliography MWE, see this answer of mine to I've just been asked to write a minimal example, what is that?. –  doncherry Feb 7 '13 at 18:17

1 Answer 1

Because you gave no MWE it is more a guess what happend.

With your given profile you have to choose in TeXnicCenter the proper profile LaTeX = PDF(BIBER) in the white field below menu point format. If you then compile twice a complete MWE, using package biblatex with option backend=biber (important, I guess this is missing!), everything should work.

Try this MWE:

%http://tex.stackexchange.com/questions/97218/how-to-automate-biber-within-texniccenter
\listfiles                % shows used packages in a list in log file
\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@article{author2000,
  author  = {AuthorA},
  title   = {Title of Article},
  journal = {Name of Journal},
  year    = {2000},
}
\end{filecontents*}

\documentclass{article}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[german]{babel}
\usepackage{csquotes}

\usepackage[%
  style=authoryear
 ,backend=biber         % to force biblatex to use biber
 ,sortlocale=de_DE
]{biblatex}
\addbibresource{\jobname.bib}

\begin{document}

\nocite{*}              % all bib entrys are printed

\printbibliography

\end{document}

Try this MWE on your computer (store it for example as file mb-biber.tex with utf8 coding) and compile it twice. If you still have errors (there should only be one correct warning caused by filecontents) please edit your question and add the error messages you get. Add also the list of used packages near the end of your log file.

I hope this answer helps you to see how important it is to show us what you are doing. That's the reason for comments asking for a MWE.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.