Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Ok, here's the deal. In December I finished writing a long document. I compiled it and went on vacations. I get back and after 2 I months compiled the exact same project with absolutely nothing changed and I get a different output. Trust me, I've changed nothing, not even the steps I use to compile.

This is what the different versions look like:

WTF!

The one on the left is the old version and the one on the right the new one. The only thing I can recall that changed in between both these files being created is that I upgraded from Ubuntu 12.04 to Ubuntu 12.10, nothing more.

The files are being displayed in Okular by the way. You'll notice that now every hyperlink has its own rectangle around it. Now where in god's name this came from I have absolutely no idea.

The pages now begin a little lower in the page (ie: the top margin has somehow increased), which made the total number of pages go from 194 to 203.

What the hell is happening here?? Please help.

I can't upload all the files because the whole project is humongous but I can upload the file which contains the bulk of the packages and options being used: here.

I'm getting this warning related to hyperref which I swear wasn't an issue before:

Package hyperref Warning: Invalid value `0'
(hyperref)                for option `pdfborder'.
(hyperref)                Option setting is ignored on input line 3941.

)

Package hyperref Message: Driver (autodetected): hpdftex.

PS: Also (for those of you who use Linux) the text inside the file is only searchable through Adobe Reader. Okular will only search text inside images (WTF!)

share|improve this question

closed as too localized by zeroth, lockstep, Thorsten, Kurt, Claudio Fiandrino Feb 8 '13 at 15:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

6  
The correct format is pdfborder=0 0 0 not pdfborder=0. Perhaps the ancient version of texlive in 12.04 did accept the latter as a bug/accident. Fixing this should remove the hyperlink boxes. –  Lev Bishop Feb 8 '13 at 4:54
4  
If you're using the TeX Live version that ships with Ubuntu, this isn't surprising. 12.04 comes with TL2009, 12.10 with TL2012. That is a pretty big difference. –  Audrey Feb 8 '13 at 5:04
3  
This almost surely has to do with the default page settings (A4 or US Letter). –  egreg Feb 8 '13 at 7:02
2  
You change absolutely nothing but the OS and most certainly the programs you use for producing this? :-) –  Martin Schröder Feb 8 '13 at 10:38
3  
@LevBishop: The correct format is pdfborder={0 0 0}. The braces are necessary to protect the spaces. –  Ulrike Fischer Feb 8 '13 at 11:46
show 1 more comment