TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Normally when I have a document with graphicx that I'd like to see rendered in draft mode I use:

\usepackage[draft]{graphicx}

However, assuming I've already called the line:

\usepackage{graphicx}

How can I set the mode to draft after this point? Looking at the docs the best I came up with was this (unsuccessful) attempt:

\ExecuteOptions{draft}
share|improve this question
up vote 8 down vote accepted
[ ... ]
\usepackage{graphicx}
\setkeys{Gin}{draft}
[ ... ]
share|improve this answer
    
That's perfect! Thank you very much! – Hooked Jan 26 '11 at 19:11
    
@Herbert Awesome! Why does \PassOptionsToPackage{draft}{graphicx} not work? I tried it and got Option clash for package graphicx (probably something to do with tikz). – macmadness86 Nov 14 '15 at 11:51
    
@macmadness86: maybe it's too late. Provide an example. – Herbert Nov 14 '15 at 19:37
    
@Herbert Yes it was added too late, however, put \setkeys in the same place and it works. I think this would warrant a new question. Understanding why \setkeys{Gin}{draft} works in places where \PassOptionsToPackage{draft}{graphicx} seems like it should be part of your answer here. – macmadness86 Nov 15 '15 at 7:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.