Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I cannot get Unicode characters to appear in the IEEE style bibliography with biblatex and biber. Shown below are minimal working examples.

\documentclass[journal]{IEEEtran}

\usepackage[style=ieee, bibencoding=utf8, backend=biber]{biblatex}
\usepackage[utf8]{inputenc}
\addbibresource{Bibliography.bib}

\begin{document}

\nocite{lee12b}
\renewcommand*{\UrlFont}{\rmfamily}
\printbibliography

\end{document}

And here are the contents of the .bib file. Note the following Unicode characters: µ (Greek mu) and ° (degree sign).

% Bibliography.bib
@article{lee12b,
    Author = {Lee, Junghyup and Cho, SeongHwan},
    Date-Added = {2013-01-23 07:05:03 +0800},
    Date-Modified = {2013-02-11 13:58:24 +0800},
    Doi = {10.1109/JSSC.2012.2204475},
    Issn = {0018-9200},
    Journal = {Solid-State Circuits, IEEE Journal of},
    Month = {Oct},
    Number = {10},
    Pages = {2527--2533},
    Printed = {1},
    Title = {{A 1.4-µW 24.9-ppm/°C Current Reference With Process-Insensitive Temperature Compensation in 0.18-µm CMOS}},
    Volume = {47},
    Year = {2012},
    }
share|improve this question
    
(1) Try to add \usepackage[T1]{fontenc}. (2) If that doesn't help, please check whether the special character are in the file generated by biber. –  tohecz Feb 11 '13 at 7:27
    
And just now found: \usepackage[utf8x]{inputenc} instead of [utf] seems to accept both mu and degree. –  tohecz Feb 11 '13 at 8:02
    
@tohecz I remember egreg commenting in one of my previous answers about a conflict between utf8x option and biblatex. I don't know what conflict though. –  hpesoj626 Feb 11 '13 at 8:27
    
I tried your suggestion and looked up the .bbl file. Yes, I see the mu and degree characters in their actual appearance (not Unicode numbers). But still they don't show up in the output PDF. –  Kit Feb 11 '13 at 8:37
    
utf8x messes it up with stuff like [PleaseinsertprerenderUnicode...] –  Kit Feb 11 '13 at 8:40

1 Answer 1

up vote 6 down vote accepted

The problem is inputenc - this doesn't cover the full range of UTF-8. If you change the inputenc line to

\usepackage{fontspec}

and then use Lualatex or Xelatex instead of PDFlatex, your example works fine.

The other option is to keep your example as it is and use pdflatex as normal but add:

\usepackage{textcomp}

and run biber like this:

biber --output_safecharsset=full --output_safechars <file.bcf>

which will convert the difficult characters which inputenc can't deal with into TeX macros. The textcomp package loads the macro definitions to deal with the macros which biber converts to (in this case, the \textdegree macro).

share|improve this answer
    
Is there a way to do this while still using pdflatex? Using other --latex flavors could potentially spawn a host of other problems, especially that I'm using the IEEEtran document class. –  Kit Feb 11 '13 at 8:39
    
Yes, I updated the answer with a pdflatex solution too. –  PLK Feb 11 '13 at 8:50
    
Thank you! It works smoothly now.. –  Kit Feb 11 '13 at 8:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.