Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using TexStudio for writing a thesis in latex. In order to access the chapters easier, I have made a separate folder for each chapter and ultimately, I have included all the tex files in the main Thesis.tex. When I want to built the pdf file, if I am on the main tex file which is called thesis.tex everything is fine; then I need to scroll down to reach a particular chapter.

When I am on another tex file, say, chapter2.tex and try to quick build, it gives error on my macbook while on my iMac it is fine. The only reason I need to compile on each of the files is that I need the to instantly view to the same place I just edited instead of scrolling all the way down.

I would appreciate your help.

share|improve this question

migrated from stackoverflow.com Feb 11 '13 at 15:35

This question came from our site for professional and enthusiast programmers.

1  
Welcome to TeX.sx! Your post was migrated here from Stack Overflow. Please register on this site, too, and make sure that both accounts are associated with each other (by using the same OpenID), otherwise you won't be able to comment on or accept answers or edit your question. –  Martin Schröder Feb 11 '13 at 18:27

1 Answer 1

up vote 4 down vote accepted

In general, you should compile the main file, this is, the one that contains the \begin{document} and the \end{document}. If you try to compile a single chapter it should give an error. Maybe iMac supports this kind of partial compiling, but in general it's not supported.

What you can do is to define your main tex as "Master document" (Options -> Define current Document as "Master Document"). This way, everytime you press the QuickBuild Button, it is going to compile the main document, even if a single chapter is selected.

Moreover, to avoid the scrolling down you can keep you pdf open.

share|improve this answer
    
thanks a lot, the problem solved. It saved me a long time –  Ramin Feb 11 '13 at 15:19
    
I'm glat to hear that. Enjoy LaTeX! :) –  Digna Feb 11 '13 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.