Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am a mac user and I installed biblatex-mla into ~/Library/texmf and I texhashed a lot. However my citation never works.

Here is my tex file:

\begin{filecontents*}{bibl1.bib}
@book{goossens93,
    keywords = {primary},
    author = "Michel Goossens and Frank Mittlebach",
    title = "The {LaTeX} Companion",
    year = "1993",
    publisher = "Addison-Wesley",
    address = "Reading, Massachusetts"
}

@book{knuth84,
    keywords = {primary},
    author = "Donald E. Knuth",
    title= "The {TeX}book",
    publisher = "Addison-Wesley",
    year = 1984
}
\end{filecontents*}

\begin{filecontents*}{bibl2.bib}
@unpublished{patashnik88,
    keywords = {secondary},
    author = "Oren Patashnik",
    title = "Using {BibTeX}",
    note = "Documentation for general BibTeX users",
    month = jan,
    year = 1988
}
\end{filecontents*}

\documentclass{article}
\usepackage[style=mla,guessmedium=false]{biblatex}
\usepackage[american]{babel}
\usepackage{csquotes}
\addbibresource{bibl1.bib}
\addbibresource{bibl2.bib}

\begin{document}
\cite{knuth84}, \cite{goossens93}, \cite{patashnik88}

\printbibliography[keyword=primary,heading=subbibliography,%
title={Primary Sources}]
\printbibliography[keyword=secondary,heading=subbibliography,%
title={Secondary Sources}]

\end{document}

I am sure I included my bib file in the current directory. Below is the log:

Package biblatex Warning: Missing 'hyperref' package.
(biblatex)                Setting hyperref=false.
(./Writing Draft.aux) (./Writing Draft.bbl)
LaTeX Warning: Citation 'knuth84' on page 1 undefined on input line 39.
LaTeX Warning: Citation 'goossens93' on page 1 undefined on input line 39.
LaTeX Warning: Citation 'patashnik88' on page 1 undefined on input line 39.
Package biblatex Warning: Keyword 'primary' not found on input line 41.
LaTeX Warning: Empty bibliography on input line 41.
Package biblatex Warning: Keyword 'secondary' not found on input line 43.
LaTeX Warning: Empty bibliography on input line 43.
[1{/usr/local/texlive/2012/texmf-var/fonts/map/pdftex/updmap/pdftex.map}]
(./Writing Draft.aux)
LaTeX Warning: There were undefined references.
Package biblatex Warning: Please (re)run Biber on the file:
(biblatex)                "Writing Draft"
(biblatex)                and rerun LaTeX afterwards.
)</usr/local/texlive/2012/texmf-dist/fonts/type1/public/amsfonts/cm/cmbx10.pfb
></usr/local/texlive/2012/texmf-dist/fonts/type1/public/amsfonts/cm/cmr10.pfb>
Output written on "Writing Draft.pdf" (1 page, 21282 bytes).
SyncTeX written on "Writing Draft.synctex.gz"
Transcript written on "Writing Draft.log".

Any help is highly appreciated.

share|improve this question

closed as too localized by lockstep, Werner, Kurt, diabonas, Martin Schröder Feb 12 '13 at 21:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to TeX.sx! Did you run Biber? –  Joseph Wright Feb 12 '13 at 11:34
    
@JosephWright I am pretty new to LaTeX. I use TexShop to run commands automatically. What is Biber BTW? –  Ben Lu Feb 12 '13 at 11:45
    
biber is a replacement for bibtex, specially written for biblatex. By default, all recent versions of biblatex output information for biber, not bibtex. To use bibtex, you must specify the "backend=bibtex" option to biblatex. To use biber, you just run it in the same way as you would bibtex. For example, if your file is called "file", you run "latex file" followed by "biber file" and then "latex file" again (perhaps twice if you are prompted to do so). –  PLK Feb 12 '13 at 11:58
    
@PLK It seems have a warning that something is not specified and use biber by default. How to specify backend=bibtex? –  Ben Lu Feb 12 '13 at 12:11
    
Change your biblatex package loading line to \usepackage[style=mla,guessmedium=false,backend=bibtex8]{biblatex} –  PLK Feb 12 '13 at 13:16

1 Answer 1

up vote 0 down vote accepted

Problem solved after I delete the space in filename and \usepackage[style=mla,guessmedium=false,backend=bibtex8]{biblatex}. Weird.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.