Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Im using a complex template to write my document. It is old and I'm having a problem. I have two separate reference list, "Internet References" and "Literature". The problem is that the references counter "[3]" on "internet References" always starts with number 3 and it should start from 1 "1". The template uses multibib package. My biblio files are: weblinks.bib and literature.bib (main file is literature.bib). I digged in all files of my project and can not find any counter that I can reset, so I assume that is some kind of "internal" counter.

Anyone knows how to reset that special counter?

In main file Diploma_Thesis.tex:

% For the two different reference lists ...
\usepackage{multibib}
\newcites{weblink}{Internet References}
.
.
\addcontentsline{toc}{chapter}{Literature}
\label{lit}
\bibliography{literature}
\bibliographystyle{alphadin}
% the style of bibliography
% start a new page

\newpage
\addcontentsline{toc}{chapter}{Internet References}
\label{wlit}
\bibliographyweblink{weblinks}
\bibliographystyleweblink{abbrv}
\newpage

The result in Literature section on PDF:

enter image description here

share|improve this question
    
Did you try to delete aux files? –  Sigur Feb 12 '13 at 15:35
    
Welcome to TeX.sx! Would you be reluctant to switch to BibLaTeX? –  Corentin Feb 12 '13 at 15:35
    
Sigur: I deleted all aux file in my project but it keeps starting at index 3. –  eduardo Feb 12 '13 at 15:40
    
Corentin: I would change but as I said it is a complex and old template (which use to write my Master Thesis) and it seems to me to be hard to do. If you can give me some hints I would be glad! –  eduardo Feb 12 '13 at 15:42
    
Probably \usepackage[resetlabels]{multibib} is what you need. –  egreg Feb 12 '13 at 16:08
show 2 more comments

1 Answer

The package multibib provides an option just for that:

\usepackage[resetlabels]{multibib}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.