TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to update MiKTeX from 2.8 to 2.9 in WinEdt. I downloaded the MiKTeX 2.9 and installed in C:/program files/Miktex 2.9. And then configure the MiKTeX in WinEdt by "Tex->Miktex-> Miktex options->roots", However, after restarting the winEdit, the MiKTeX Version is still 2.8. May someone help me?

share|improve this question

closed as too localized by Speravir, Werner, diabonas, Martin Schröder, zeroth Feb 16 '13 at 19:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

As far as I recall the recommended procedure for moving from 2.8 to 2.9 was to first completely uninstalling 2.8 and then running afresh install of 2.9. My suspicion is that the 2.8 env. variables occur before the 2.9 making 2.8 the "default". This has nothing to do with WinEdt so the best way forsward is to remove MiKTeX 2.8 and2.9 altogether and then install a fresh version of 2.9. – Peter Jansson Feb 13 '13 at 7:20
@PeterJansson thanks, solved it. – sweetyBaby Feb 13 '13 at 7:40
@PeterJansson: No it is not necessary to do a complete uninstall. But one should check the environment variables. – Ulrike Fischer Feb 13 '13 at 8:55
@UlrikeFischer there is another new problem, pls refer to tex.stackexchange.com/questions/97985/…, thanks – sweetyBaby Feb 13 '13 at 9:01
This link should help: tex.stackexchange.com/a/89764 – azetina Feb 14 '13 at 23:19

I have solved it just rename the original MikTex 2.8 folder so that Winedt can not find it. Therefore, it uses the MikTex 2.9.

share|improve this answer
I’m sure, this is not a real solution, but a (bad!) workaround. I do not know, how WinEdt usually finds the executables, but it seems to me it can search the system path. So you should do, waht Ulrike already suggested: Check the environment variable PATH and if needed remove the path to MiKTeX 2.8 from it. At first put this in the command prompt on your system: echo %path%. – Speravir Feb 14 '13 at 21:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.