Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using AUCTeX with emacs 24.1 on Ubuntu 11.10. I have the TeX Command set to compile using LuaTeX and to produce pdfs. Everything works except that the name of the pdf changes from the file name to textput.pdf. Not a super big deal but the same thing happens with the index and I have to rename it to the file name in order to get the document to compile with an index (defeating somewhat the purpose of the convenience of having the Index command available in AUCTeX).

I've seen reports of this issue elsewhere on the internet but not being very knowledgeable about the inner workings of emacs I have been unable to figure out how to fix this behavior. I had been compiling everything with XeLaTeX and it all worked as expected with respect to the resulting file names, so this appears to be a problem with LuaTeX or how AUCTeX deals with LuaTeX.

share|improve this question

1 Answer 1

up vote 11 down vote accepted

This is indeed a bug in AUCTeX.

To fix it you need to customize TeX-command-list so that the LaTeX entry has the associated command equal to

%`%l --jobname=%s %(mode)%' %t

which includes an explicit setting of jobname to match that of your current file. The relevant part of the customize buffer looks like this (you need to have opened a tex file, before this option becomes available):

Sample buffer

I have been using this regularly for sometime now without problems.

share|improve this answer
    
Thank you. It took a minute to find the place to customize the proper entry but I did and now it works as expected. –  bfootdav Feb 13 '13 at 16:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.