Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I meet the problem that when running the code, WinEdt says:

The required **** file is missing....

after updating MiKTeX 2.8 to 2.9 version. And I have tried to install the package that missing files in by Package Manager, however, after installing successfully, I still meet the same problem says the same file is missing. Can someone help me?

share|improve this question

closed as too localized by Speravir, Werner, Kurt, Heiko Oberdiek, Guido Feb 14 '13 at 5:41

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
There is currently a severe bug in the miktex-runtime-bin. The only known way to get around it (until it has been corrected) is to install only the basic version of miktex (which contains an older version) (And naturally not to update this package). It is also possible to get around the problem by replacing miktex209-core.dll with an older version. Perhaps you can find it in a repository which has some delay. miktex.org/pkg/repositories –  Ulrike Fischer Feb 13 '13 at 15:52
    
I have an old copy of the file you mention and...it works. Anybody needs it? –  gcass Feb 13 '13 at 17:02
    
@UlrikeFischer I updated miktex-runtime-bin and miktex-bin today. Some of my tex-files cannot be compiled anymore; there are suddenly hundreds of error messages. Replacing miktex209-core.dll with an older version does not help. Are there any other files I have to replace? I am asking because I want to avoid a new installation of my miktex version. –  partial81 Feb 13 '13 at 18:27
    
@UlrikeFischer You get the error also if you update your settings, happened to me the other day... –  Yiannis Lazarides Feb 13 '13 at 18:28
1  
The story is that MikTeX updates are too often buggy in recent years. Apart of the evident problem with updated binaries which don't want to see installed packages, the MikTeX update wizard announces that amsmath package is obsolete and must be removed. Please, don't believe in that. –  Igor Kotelnikov Feb 14 '13 at 3:26

1 Answer 1

The problem I encountered after updating this morning are caused by the file MiKTeX209-core.dll.

I have an old copy (not updated) which I posted on my website:

http://www.statistica.unimib.it/utenti/cassese/MiKTeX209-core.dll

It is enough to copy it and paste it and that fixes the bug. At least it did for me

share|improve this answer
    
@PeterJansson which is not available for a new user. gcass: Since you cannot post comments yet, moderator will convert these to comments. This answer actually looks that you try to answer the question, but it is not clear. If the link you provide should really solve the problem, please explain better what is it about ;) –  tohecz Feb 13 '13 at 17:22
    
Welcome to TeX.sx! Usually, we don't put a greeting or a "thank you" in our posts. While this might seem strange at first, it is not a sign of lack of politeness, but rather part of our trying to keep everything very concise. Accepting and upvoting answers is the preferred way here to say "thank you" to users who helped you. –  Kurt Feb 13 '13 at 18:19
    
@gcass Where did you drop it? –  Yiannis Lazarides Feb 13 '13 at 18:26
    
@YiannisLazarides: copy it to ...\MiKTeX 2.9\miktex\bin, but if you use images in your document you will get only a dvi file (with error messages if you normally want a pdf output). –  Kurt Feb 13 '13 at 18:52
    
@Kurt yes, there is some problems in outputing pdf! is there any other way to slove the this problem. –  sweetyBaby Feb 14 '13 at 3:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.