Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm a new Ubuntu user and I'm trying to use all the programs I regularly use on Windows on Ubuntu, one of which is TeXworks. When I try to compile my .tex file using the green arrow circle in the top left corner of the window, this error pops up:

(/usr/share/texlive/texmf-dist/tex/latex/psnfss/ot1ppl.fd)
kpathsea: Running mktextfm pplr7t
/usr/share/texlive/texmf/web2c/mktexnam: Could not map source abbreviation  for pplr7t.
/usr/share/texlive/texmf/web2c/mktexnam: Need to update ?
mktextfm: Running mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input pplr7t
This is METAFONT, Version 2.718281 (TeX Live 2012/Debian)

kpathsea: Running mktexmf pplr7t

! I can't find file `pplr7t'.
<*> ...:=ljfour; mag:=1; nonstopmode; input pplr7t

Please type another input file name
! Emergency stop.
<*> ...:=ljfour; mag:=1; nonstopmode; input pplr7t

Transcript written on mfput.log.
grep: pplr7t.log: No such file or directory
mktextfm: `mf-nowin -progname=mf \mode:=ljfour; mag:=1; nonstopmode; input pplr7t' failed to make pplr7t.tfm.
kpathsea: Appending font creation commands to missfont.log.

! Font OT1/ppl/m/n/10.95=pplr7t at 10.95pt not loadable: Metric (TFM) file not 
found.
<to be read again> 
                   relax 
l.13 \begin{document}

? 
Process interrupted by user

I am missing this font file pplr7t and I can't figure out how to either add it or update whatever file or directory I need to update. Any help with this specific problem, and then some advice for general problem solving with LaTeX packages (where their directories are located, how to get and update packages) would be greatly appreciated.

share|improve this question

closed as too localized by lockstep, Joseph Wright Apr 6 '13 at 21:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

5  
Have you installed the deb package texlive-fonts-recommended from the repositories? –  ernesto Feb 13 '13 at 17:38
    
Welcome to TeX.SX. –  Claudio Fiandrino Feb 13 '13 at 17:43
1  
@ernesto I had the same problem on OSX (using macports), installing the package texlive-fonts-recommended as you suggested fixed the problem. –  Andre Holzner May 3 '13 at 10:54
2  
After a complete desktop rebuild and an installation of (I thought) all the necessary LaTeX packages, I had this exact same error. This page was the first Google result for 'pplr7t', and @ernesto's comment solved my problem. +1 on question and +1 on answer. –  dg99 Nov 6 '13 at 18:37
    
I can't figure out why this question was closed, but it was extremely useful. For reasons I don't understand, installing the package texworks on Ubuntu does not install everything. A novice user is forced to learn about all kinds of dependencies that are totally unobvious. Thanks to @ernesto for coming to the rescure on this one. I had to find 3 separate stack exchange postings just to get a document that worked on windows to work. –  Dov Jun 20 at 13:14

Browse other questions tagged or ask your own question.