Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This question already has an answer here:

I have MikTeX 2.9 installation and Strawberry Perl 5.10.1.5.

All the latexdiff, latexdiff-fast, latexidff-so paths seem to be present in the scripts.ini file and their .exe files in the miktex/bin/x64.

Somehow when I try to run latexdiff command in the directory where the two versions of .tex files are present, I get this error

latexdiff: The Perl script could not be found.

latexdiff: Data: scripts/latexdiff/perl/latexdiff.pl

When I run the command, a pop-up window asks for installation of latexdiff.pl and I press ok, but it ends up in the error shown above. I followed some posts with similar problem, but couldn't find a solution.

Any help would be appreciated.

share|improve this question
1  
This seems to be a bug in MiKTeX: With the call of latexdiff you actually make a call of latexdiff.exe, what is a wrapper. In this wrapper the path shown in th error message seem s to be hardcoded, but it is empty on my machine. So file a bug in the MiKTeX Bugs Tracker. BTW there were recently also problems with other perl based scripts in MiKTeX. –  Speravir Feb 16 '13 at 19:13
    
I think, it is not really related, but let me point you to latexdiff problem in MikTex 2.8 after update: “Perl script not found”. –  Speravir Feb 16 '13 at 19:18
    
@Speravir I came across this post before I posted mine, but the post didn't really suggest a solution. I'll try to file a bug with the MiKTeX Bugs Tracker. –  user24021 Feb 17 '13 at 9:40
    
@Speravir MiKTeX Bugs Tracker doesn't allow to me file the bug. I created an account in SourceForge and tried creating a ticket, but it says 'We are sorry your request could not be processed' and doesn't give any further information. –  user24021 Feb 17 '13 at 9:59
add comment

marked as duplicate by Speravir, Gonzalo Medina, mafp, Jesse, cmhughes Feb 6 at 4:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

I've just faced this exact problem with latexdiff.

Follow the solution found here for a different package,

http://www.latex-community.org/forum/viewtopic.php?f=9&t=14677

but also rename the latexdiff perl files to also have a .pl extension.

share|improve this answer
    
Welcome to TeX.sx! –  Peter Jansson Mar 21 '13 at 11:11
4  
Please consider to include more details, so that your answer becomes self-contained. –  lockstep Mar 21 '13 at 11:14
    
I followed this approach (made a folder perl in scripts/latexdiff, moved all files there; added .pl to all of them and refresh FNDB) and I still get the error. Did I miss something? –  remus Sep 10 '13 at 13:01
    
I moved latexdiff.pl to my working folder and invoked perl latexdiff.pl old.tex new.tex > diff.tex but I would like to use it normally from miktex. –  remus Sep 10 '13 at 13:14
add comment

Maybe not what you want but have you tried installing Cygwin, Perl and latexdiff there? I think installing TeXLive is also an option but installing 2Gb software just to have access to a script might be too much. I do understand how latexdiff can be important. Several journals where I was submitting asked me for the difference between submitted and reviewed versions of papers.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.