Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I get the error message Error: Unknown option pages=some for package background, when I tried to compile the following code from the manual of the Background package.

\documentclass{article}
\usepackage[pages=some,placement=top]{background}
\usepackage{lipsum}
\begin{document}
\lipsum[1-5]
\newpage
\backgroundsetup{contents=A,color=yellow}
\BgThispage
\lipsum[1-5]
\newpage
\backgroundsetup{contents=B,color=blue}
\BgThispage
\lipsum[1-5]
\end{document} 

What am I doing wrong?

share|improve this question

closed as too localized by Speravir, Martin Schröder, Kurt, Werner, Marco Daniel Feb 17 '13 at 7:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This works fine for me with the latest TeXLive2012. What version are you using? I'd recommend updating to the latest release. And I confirmed that I get the same error message as you with TeXLive 2011. –  Peter Grill Feb 16 '13 at 22:13
    
The manual and your example have the key as pages, your error has page. Which did you use and what version of background do you have installed? –  Joseph Wright Feb 16 '13 at 22:14
    
@JosephWright: I googled and found the following manual of version 1. (texdoc.net/texmf-dist/doc/latex/background/background.pdf) –  Sony Feb 17 '13 at 0:24
    
@PeterGrill: I have TeXLive2012. That is strange. –  Sony Feb 17 '13 at 0:25
    
@Sony the reason is that when TeX Live2012 was made public, it shipped version 1.1 of background; only two months after (or so) I uploaded version 2.0 to CTAN. So if you haven't updated your TeX Live2012 installation after September 2012, it will still contain version 1.1. –  Gonzalo Medina Feb 17 '13 at 2:09

1 Answer 1

up vote 6 down vote accepted

With the newest version (2.0) of the package, the code you posted produces no errors; with older versions you will get the error mentioned, so it seems that you are using an outdated version.

In older versions, instead of

\usepackage[pages=some,placement=top]{background}

you have to use

\usepackage[some,top]{background}

additionally, \backgroundsetup is not available in older versions so you will have to use the older user interface described in Section 4 Compatibility with version 1.0 of the documentation, and write something like

\documentclass{article}
\usepackage[some,top]{background}
\usepackage{lipsum}
\begin{document}
\lipsum[1-5]
\newpage
\SetBgContents{A}
\SetBgColor{yellow}
\BgThispage
\lipsum[1-5]
\newpage
\SetBgContents{B}
\SetBgColor{blue}
\BgThispage
\lipsum[1-5]
\end{document}

Version 2.0 (the current one) has a better user interface and some additional features, so I recommend updating the package.

share|improve this answer
    
I checked with TeXLiveUtility and it says that the background package is installed. But, according to README it is the version 1. How can I get the version 2? –  Sony Feb 17 '13 at 0:37
    
@Sony in TeX Live you can use the package manager; once an appropriate repository has been enabled, run in a terminal tlmgr update --self --all (this will update your LaTeX system) or simply tlmgr update background (this will update only the package). Another option is to install the package manually; there are some answers in this site explaining how to do this (basically, run latex on the file background.ins (available here) and move the generated file background.sty somewhere TeX can find it.) –  Gonzalo Medina Feb 17 '13 at 1:47
    
Got it to work! Thanks. –  Sony Feb 17 '13 at 2:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.