Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I use \listoffigures and \listoftables. Both commands create line breaks for items from different chapters. How can you stop that?

Screenshot:

enter image description here

share|improve this question
1  
What class are you using? It seems scrbook or scrreprt; it's important to know. –  egreg Feb 17 '13 at 15:50
    
I use: scrreprt –  Benny Neugebauer Feb 17 '13 at 15:51
1  
Try \KOMAoptions{listof=nochaptergap} in your preamble. –  Henri Menke Feb 17 '13 at 15:56
    
Thank you! It worked! –  Benny Neugebauer Feb 17 '13 at 15:59
1  
I'll repost that, so you can mark the question answered. –  Henri Menke Feb 17 '13 at 17:34
add comment

2 Answers 2

up vote 3 down vote accepted

According to table 3.20 in the KOMA-Script manual the following snippet added to the preamble will solve the issue

\KOMAoptions{listof=nochaptergap}

alternatively you can pass this option directly to the koma-documentclass

\documentclass[listof=nochaptergap]{scrreprt}
share|improve this answer
add comment

It's explained in section 3.16 of the manual of KoMa-Script:

\documentclass
 [... other options ...,
  chapteratlists=0pt]{scrreprt}
share|improve this answer
    
Thanks! It worked. –  Benny Neugebauer Feb 17 '13 at 18:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.