Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have just started to use an Apple computer and want to use Texmaker. But forward/inverse search does not work at all. I am trying to follow the instructions but I'm not successful. What could I be doing wrong?

share|improve this question
    
I can't get it to work either. Have you considered using TeXShop pages.uoregon.edu/koch/texshop instead? It's much more mature and a lot faster and synchs properly between PDF and source. –  Alan Munn Jan 30 '11 at 1:37
    
The Texmaker website only claims that Texmaker has forward/inverse search for DVIs. It doesn't say anything about PDFs. Maybe the problem is that you are compiling to PDF? –  Caramdir Jan 30 '11 at 2:48
    
@Petya: I added an actual question to the question; hope that is okay. Maybe you could provide some details what exactly you have tried? –  Caramdir Jan 30 '11 at 2:51
    
Have you tried a previous version of the software, I am using a portable version which works fine for me, you can download it from this address: –  Yasser Sobhdel Jan 30 '11 at 7:45
1  
@Petya Assuming you downloaded and installed MacTeX, it should already be installed, so there's really nothing to do except try it. It should be in a folder named TeX in your Applications folder. –  Alan Munn Jan 31 '11 at 2:39
show 6 more comments

3 Answers

up vote 5 down vote accepted

Here is my way to fix the problem I asked - I think it could be helpful.

  1. Install the Skim PDF-viewer. It is free.
  2. In TeXmaker configuration choose the external PDF-viewer and place there the following line:

     /Applications/Skim.app/Contents/SharedSupport/displayline @ %.pdf  
    

    (I think it gives the possibility of the forward search.)

  3. In the Skim preferences edit custom command in Sync section. The command must be:

    /Applications/texmaker.app/Contents/MacOS/texmaker
    

    with argument

    "%file" -line %line
    

Now you can perform the inverse search. How to do it? Shift-Command-Click and the cursor moves to the corresponding place in the tex-file.

share|improve this answer
add comment

Have you add the option

-synctex=1

for pdflatex, xelatex. However, version 2.2 can do forward/inverse search only on 1 files latex source.

share|improve this answer
    
Does this actually work on a Mac? I have v.2.2 and with -synctex=1 there is still no synching. –  Alan Munn Jan 30 '11 at 19:56
    
on Mac I don't know. One more possible mistake is pdfsync package. You should not use it. –  S. Boonto Jan 30 '11 at 20:09
    
@SBoonto But the question specifically asked about Mac. –  Alan Munn Jan 30 '11 at 20:14
    
Thank you for your answer. Real solution (one possible) is in my own answer. –  Petya Jan 31 '11 at 1:43
    
@Munn sorry for that. I just thought Texmaker is cross-platform editor and it use its own internal pdf viewer. In YouTube that I saw the solution at xm1math.net/texmaker/log.html, is for Ubuntu. I used the same method on Windows XP,7 and it works very well. So I think may be this will work for Mac too. –  S. Boonto Jan 31 '11 at 8:01
add comment

If you put the -synctex=1 option in the following position then it works!!. At the end of the line it hasn't worked for me!!.

TexMaker -> Preferences -> Commands -> PdfLaTeX

"/usr/texbin/pdflatex" -synctex=1 -interaction=nonstopmode %.tex
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.