Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have an example here of an article document using pdflatex, bibtex, and natbib, where the Č character for Čermak isn't sorted in the bibliography correctly. I don't understand why not. Both files are encoded as utf-8 by my editor, and the pdf shows the character correctly. If instead I use {\v C} in the bib file, the sorting is correct (so obviously this is my current workaround, but I don't want to have to do it for all my refs if I don't have to).

\documentclass[10pt,a4paper,final]{article}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{natbib}
\begin{document}
See \cite{cermak_heat_1985,ingebritsen_sanford_1999}
\bibliographystyle{apalike} 
\bibliography{mwe} 
\end{document}

and the bib file:

@BOOK{ingebritsen_sanford_1999,
  title = {Groundwater in geologic processes},
  publisher = {Cambridge University Press},
  year = {1999},
  author = {Ingebritsen, S. E. and Sanford, Ward E.},
  pages = {341}
}
@ARTICLE{cermak_heat_1985,
  author = {Čermak, Vladimír and Jetel, Ján},
  title = {Heat flow and ground water movement in the {B}ohemian {C}retaceous {B}asin
    ({C}zechoslovakia)},
  journal = {Journal of Geodynamics},
  year = {1985},
  volume = {4},
  pages = {285--303},
  number = {1–4},
}
share|improve this question
1  
Ahh, my .bib files are full of {\noopsort{ZZZ}}{\v Z}ivanovi{\'c} ... a little trick which sorts Ž "correctly", i.e. not as Z. (\noopsort is of course defined as \providecommand{\noopsort}[1]{}.) I'm also switching bo biblatex/biber as soon as I have the time to go through my .bib files. –  Sašo Živanović Feb 21 '13 at 0:56
add comment

1 Answer

up vote 7 down vote accepted

BibTeX can not handle UTF8 characters, when it comes to sorting everything must be ASCII. So the Č is ignored in sorting. To deal with other characters, BibTeX has the rule that {\command{C}} is supposed to be a fancy accent, and should be sorted as C. Your options are thus to either switch to biblatex, or encode all author names with the "fancy accent" style:

author = {{\v{C}}ermak, Vladim{\'{\i}}r and Jetel, J{\'a}n}

See also the manual for the ugly details.

share|improve this answer
    
Ah, good one bibtex. Thanks @mafp for the quick answer! I hadn't heard of biblatex, but it looks the goods. –  a different ben Feb 21 '13 at 0:27
    
The problem is that .bib files are a useful resource to share (among colleages, have some common ones for the project, ...), and in that setting you'd better have ASCII-only files (no, BibLaTeX doesn't solve the character encoding problems, you need extra pieces like biber for that; and that one I could never get to even build). –  vonbrand Feb 21 '13 at 3:30
    
Ahh this could be more trouble than it's worth. I have texlive 2009, so no biber pre-installed. I also needed to install biblatex from the Ubuntu repositories as a pre-requisite to biber. biber versions are closely related to biblatex versions, and there are specific compatibilities - see any of the recent biber docs for the compatibility table. The Ubuntu 12.04 (precise) biblatex is v1.7x, so need biber v0.99. I got the binary from sf.net and put it in ~/bin. –  a different ben Feb 21 '13 at 3:56
    
There is a natbib package option for compatibility with natbib citation commands (\citep, \citet). –  a different ben Feb 21 '13 at 4:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.